summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-08-09 02:00:15 +0200
committerMuflone2015-08-09 02:00:15 +0200
commit92d9fed65e95f00721b03a686b8efbddd46cffe1 (patch)
treede0dea23de349470357f5669d2f4e48f11618412
downloadaur-92d9fed65e95f00721b03a686b8efbddd46cffe1.tar.gz
New package gnome-manpages-git 20130101.15.e660878-1
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD64
-rw-r--r--gnome-manpages-git.install12
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9bef6adc994
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = gnome-manpages-git
+ pkgdesc = Various man pages for GNOME related libraries
+ pkgver = 20130101.15.e660878
+ pkgrel = 1
+ url = https://github.com/chergert/gnome-manpages/
+ install = gnome-manpages-git.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = man-db
+ conflicts = gnome-manpages
+ source = git+https://github.com/chergert/gnome-manpages.git
+ sha256sums = SKIP
+
+pkgname = man-pages-clutter-git
+
+pkgname = man-pages-gdk3-git
+
+pkgname = man-pages-gio2-git
+
+pkgname = man-pages-glib2-git
+
+pkgname = man-pages-gobject2-git
+
+pkgname = man-pages-gtk3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b945e16afdb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgbase=gnome-manpages-git
+pkgname=('man-pages-clutter-git' 'man-pages-gdk3-git' 'man-pages-gio2-git' 'man-pages-glib2-git' 'man-pages-gobject2-git' 'man-pages-gtk3-git')
+pkgver=20130101.15.e660878
+pkgrel=1
+pkgdesc="Various man pages for GNOME related libraries"
+url="https://github.com/chergert/gnome-manpages/"
+arch=('any')
+makedepends=('git')
+depends=('man-db')
+conflicts=('gnome-manpages')
+license=('GPL2')
+install="${pkgbase}.install"
+source=("git+https://github.com/chergert/gnome-manpages.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgbase%-*}"
+ printf $(git log -1 --format="%cd" --date=short | sed 's|-||g').$(git rev-list --count HEAD).$(git describe --always)
+}
+
+_package() {
+ _ARCHIVE="$1-manpages.tar.gz"
+ cd "${pkgbase%-*}"
+ # Remove previous extracted manuals
+ [ -d "${_ARCHIVE%.tar.gz}" ] && rm -rf "${srcdir}/${pkgbase%-*}/${_ARCHIVE%.tar.gz}"
+ # Extract man pages
+ mkdir "${_ARCHIVE%.tar.gz}"
+ tar xzf "${_ARCHIVE}" -C ${_ARCHIVE%.tar.gz}
+ # Install man pages
+ if [ $(ls -1 "${_ARCHIVE%.tar.gz}"/*.1 2> /dev/null | wc -l) -gt 0 ]; then
+ install -m 755 -d "${pkgdir}/usr/share/man/man1"
+ install -m 644 -t "${pkgdir}/usr/share/man/man1" "${_ARCHIVE%.tar.gz}"/*.1
+ gzip -r "${pkgdir}/usr/share/man/man1/"
+ fi
+ install -m 755 -d "${pkgdir}/usr/share/man/man3"
+ install -m 644 -t "${pkgdir}/usr/share/man/man3" "${_ARCHIVE%.tar.gz}"/*.3
+ gzip -r "${pkgdir}/usr/share/man/man3/"
+}
+
+package_man-pages-clutter-git() {
+ _package "clutter"
+}
+
+package_man-pages-gdk3-git() {
+ _package "gdk3"
+}
+
+package_man-pages-gio2-git() {
+ _package "gio2"
+}
+
+package_man-pages-glib2-git() {
+ _package "glib2"
+}
+
+package_man-pages-gobject2-git() {
+ _package "gobject2"
+}
+
+package_man-pages-gtk3-git() {
+ _package "gtk3"
+}
diff --git a/gnome-manpages-git.install b/gnome-manpages-git.install
new file mode 100644
index 000000000000..7be2e9d1ddc5
--- /dev/null
+++ b/gnome-manpages-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ mandb -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+