summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-06-08 11:49:18 -0600
committerAinola2015-06-08 11:49:18 -0600
commit99c1bce3b42e897d1d581d271dc4f7e8bd28859d (patch)
tree284693b7563704a4e44e3f29f7695a147343f9f4
downloadaur-99c1bce3b42e897d1d581d271dc4f7e8bd28859d.tar.gz
initial
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
-rw-r--r--gnome-mpv.install12
-rw-r--r--remove-inline.patch152
4 files changed, 223 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d225103f2b55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gnome-mpv
+ pkgdesc = GNOME frontend for MPV
+ pkgver = 0.4
+ pkgrel = 2
+ url = https://github.com/gnome-mpv/gnome-mpv
+ install = gnome-mpv.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = intltool
+ depends = gtk3
+ depends = mpv
+ conflicts = gnome-mpv-git
+ source = https://github.com/gnome-mpv/gnome-mpv/archive/v0.4.tar.gz
+ source = gnome-mpv.install
+ source = remove-inline.patch
+ sha256sums = 3b72cc9c070d6e5efd4390b1ab333b50e7f4da380452169a40754be4128d4ffc
+ sha256sums = 2f53c431d6a6ed51b5abe0f42f90bdcd9c1cc7776962e8f8bc0d77a95e114f51
+ sha256sums = 59f5475a40b3eaa68bb6ea6955b219ee148f8301337caf3fbfe6e7dd3958b0ff
+
+pkgname = gnome-mpv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6509258d1d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Ainola
+
+pkgname=gnome-mpv
+pkgver=0.4
+pkgrel=2
+pkgdesc="GNOME frontend for MPV"
+arch=('i686' 'x86_64')
+url="https://github.com/gnome-mpv/gnome-mpv"
+license=('GPL3')
+depends=('gtk3' 'mpv')
+makedepends=('intltool')
+conflicts=('gnome-mpv-git')
+source=("https://github.com/gnome-mpv/gnome-mpv/archive/v${pkgver}.tar.gz"
+ "${pkgname}.install"
+ "remove-inline.patch")
+sha256sums=('3b72cc9c070d6e5efd4390b1ab333b50e7f4da380452169a40754be4128d4ffc'
+ '2f53c431d6a6ed51b5abe0f42f90bdcd9c1cc7776962e8f8bc0d77a95e114f51'
+ '59f5475a40b3eaa68bb6ea6955b219ee148f8301337caf3fbfe6e7dd3958b0ff')
+install=('gnome-mpv.install')
+
+prepare() {
+ # Fix issue #27 (https://github.com/gnome-mpv/gnome-mpv/issues/27) until next release.
+ patch -p0 < remove-inline.patch
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ autoreconf -sfi
+ intltoolize -c --automake
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/gnome-mpv.install b/gnome-mpv.install
new file mode 100644
index 000000000000..c317fbaca442
--- /dev/null
+++ b/gnome-mpv.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/remove-inline.patch b/remove-inline.patch
new file mode 100644
index 000000000000..b5cef0b2d547
--- /dev/null
+++ b/remove-inline.patch
@@ -0,0 +1,152 @@
+*** gnome-mpv-0.4/src/common.c 2015-05-30 15:01:05.199253876 -0600
+--- gnome-mpv-0.4/src/common.c 2015-05-30 15:01:05.199253876 -0600
+***************
+*** 28,41 ****
+ #include "control_box.h"
+ #include "playlist_widget.h"
+
+! inline gchar *get_config_string( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key )
+ {
+ return g_key_file_get_string(ctx->config_file, group, key, NULL);
+ }
+
+! inline void set_config_string( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ const gchar *value)
+--- 28,41 ----
+ #include "control_box.h"
+ #include "playlist_widget.h"
+
+! gchar *get_config_string( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key )
+ {
+ return g_key_file_get_string(ctx->config_file, group, key, NULL);
+ }
+
+! void set_config_string( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ const gchar *value)
+***************
+*** 44,50 ****
+ g_key_file_set_string(ctx->config_file, group, key, value?value:"");
+ }
+
+! inline gboolean get_config_boolean( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ gboolean defaultval )
+--- 44,50 ----
+ g_key_file_set_string(ctx->config_file, group, key, value?value:"");
+ }
+
+! gboolean get_config_boolean( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ gboolean defaultval )
+***************
+*** 60,66 ****
+ return !keyfile_error?result:defaultval;
+ }
+
+! inline void set_config_boolean( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ gboolean value)
+--- 60,66 ----
+ return !keyfile_error?result:defaultval;
+ }
+
+! void set_config_boolean( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ gboolean value)
+***************
+*** 68,74 ****
+ g_key_file_set_boolean(ctx->config_file, group, key, value);
+ }
+
+! inline gchar *get_config_dir_path(void)
+ {
+ return g_strconcat( g_get_user_config_dir(),
+ "/",
+--- 68,74 ----
+ g_key_file_set_boolean(ctx->config_file, group, key, value);
+ }
+
+! gchar *get_config_dir_path(void)
+ {
+ return g_strconcat( g_get_user_config_dir(),
+ "/",
+***************
+*** 76,82 ****
+ NULL );
+ }
+
+! inline gchar *get_config_file_path(void)
+ {
+ return g_strconcat( get_config_dir_path(),
+ "/"
+--- 76,82 ----
+ NULL );
+ }
+
+! gchar *get_config_file_path(void)
+ {
+ return g_strconcat( get_config_dir_path(),
+ "/"
+*** gnome-mpv-0.4/src/common.h 2015-05-30 15:01:05.199253876 -0600
+--- gnome-mpv-0.4/src/common.h 2015-05-30 15:01:05.199253876 -0600
+***************
+*** 47,69 ****
+ GtkListStore *playlist_store;
+ };
+
+! inline gchar *get_config_string( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key );
+! inline void set_config_string( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ const gchar *value );
+! inline gboolean get_config_boolean( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ gboolean defaultval );
+! inline void set_config_boolean( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ gboolean value);
+! inline gchar *get_config_dir_path(void);
+! inline gchar *get_config_file_path(void);
+ gboolean load_config(gmpv_handle *ctx);
+ gboolean save_config(gmpv_handle *ctx);
+ gchar *get_path_from_uri(const gchar *uri);
+--- 47,69 ----
+ GtkListStore *playlist_store;
+ };
+
+! gchar *get_config_string( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key );
+! void set_config_string( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ const gchar *value );
+! gboolean get_config_boolean( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ gboolean defaultval );
+! void set_config_boolean( gmpv_handle *ctx,
+ const gchar *group,
+ const gchar *key,
+ gboolean value);
+! gchar *get_config_dir_path(void);
+! gchar *get_config_file_path(void);
+ gboolean load_config(gmpv_handle *ctx);
+ gboolean save_config(gmpv_handle *ctx);
+ gchar *get_path_from_uri(const gchar *uri);