summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-06-26 12:19:30 -0600
committerMark Wagie2020-06-26 12:19:30 -0600
commite6b1db97f8d6c10b00dfcc0375716b24b34924e8 (patch)
tree58dac9ba26f8fd29af7d13121870d88c62a9fee7
parentd8f885ff400b6bdb30446f05c5d2c03b9763e9f3 (diff)
downloadaur-e6b1db97f8d6c10b00dfcc0375716b24b34924e8.tar.gz
adjust makedepends, add check
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 708c8a53a1b9..ff74174b90a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = gnome-network-displays-git
pkgdesc = Miracast implementation for GNOME
- pkgver = 0.90.3.r4.gb59cd2f
+ pkgver = 0.90.3.r25.g018fe69
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/gnome-network-displays
arch = any
license = GPL3
+ checkdepends = appstream
makedepends = git
makedepends = meson
- makedepends = appstream-glib
depends = gtk3
depends = faac
depends = gst-plugins-ugly
diff --git a/PKGBUILD b/PKGBUILD
index c345288ee2e9..6bfc2c6d2755 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=gnome-network-displays-git
-pkgver=0.90.3.r4.gb59cd2f
+pkgver=0.90.3.r25.g018fe69
pkgrel=1
pkgdesc="Miracast implementation for GNOME"
arch=('any')
@@ -8,7 +8,8 @@ url="https://gitlab.gnome.org/GNOME/gnome-network-displays"
license=('GPL3')
depends=('gtk3' 'faac' 'gst-plugins-ugly' 'gst-rtsp-server' 'libpulse' 'libnm'
'python-gobject' 'x264' 'xdg-desktop-portal')
-makedepends=('git' 'meson' 'appstream-glib')
+makedepends=('git' 'meson')
+checkdepends=('appstream')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://gitlab.gnome.org/GNOME/gnome-network-displays.git')
@@ -21,9 +22,13 @@ pkgver() {
build() {
arch-meson "${pkgname%-git}" build
- ninja -C build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
}