summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors3rj1k2022-04-24 22:35:31 +0300
committers3rj1k2022-04-24 22:35:31 +0300
commitbeb65ff40b56b477043188b26a48c57e8d97957a (patch)
tree34a621e914a15e187575ce9fda2814d549c96cb7
parent2521e2f9a1fe6e2df3118e651c3f5ec50e507d24 (diff)
downloadaur-beb65ff40b56b477043188b26a48c57e8d97957a.tar.gz
Update schema
Signed-off-by: s3rj1k <evasive.gyron@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--minimize.patch32
3 files changed, 36 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 833f43bd3444..40c19dba47d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-panel-minimal
pkgdesc = Panel of GNOME Flashback (minimal build)
pkgver = 3.44.0+0a5a7081f
- pkgrel = 3
+ pkgrel = 4
url = https://wiki.gnome.org/Projects/GnomePanel
arch = x86_64
license = GPL
@@ -17,6 +17,6 @@ pkgbase = gnome-panel-minimal
source = git+https://gitlab.gnome.org/GNOME/gnome-panel.git#tag=3.44.0
source = minimize.patch
sha256sums = SKIP
- sha256sums = 4b3cf4712ba64363f62185c3fead3fc7726bf4194f03260ae82bd8dfb95e58cc
+ sha256sums = 24b201303235c28a31b59a38fb5d8ef472ac2af51c96e8ec7c540d4a40d0fffd
pkgname = gnome-panel-minimal
diff --git a/PKGBUILD b/PKGBUILD
index 9a01852b4a3a..cea25ad61389 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname=gnome-panel
_pkgver=3.44.0
pkgname=${_pkgname}-minimal
pkgver=3.44.0+0a5a7081f
-pkgrel=3
+pkgrel=4
pkgdesc='Panel of GNOME Flashback (minimal build)'
arch=('x86_64')
url='https://wiki.gnome.org/Projects/GnomePanel'
@@ -17,7 +17,7 @@ conflicts=("${_pkgname}")
source=("git+https://gitlab.gnome.org/GNOME/gnome-panel.git#tag=${_pkgver}"
'minimize.patch')
sha256sums=('SKIP'
- '4b3cf4712ba64363f62185c3fead3fc7726bf4194f03260ae82bd8dfb95e58cc')
+ '24b201303235c28a31b59a38fb5d8ef472ac2af51c96e8ec7c540d4a40d0fffd')
pkgver() {
cd "${srcdir}/${_pkgname}"
diff --git a/minimize.patch b/minimize.patch
index 88a0a714dcc7..d0e6896256f2 100644
--- a/minimize.patch
+++ b/minimize.patch
@@ -233,6 +233,38 @@ index 67339eae9..879905876 100644
org.gnome.gnome-panel.applet.initial-settings.gschema.xml \
org.gnome.gnome-panel.gschema.xml \
org.gnome.gnome-panel.object.gschema.xml \
+diff --git a/data/org.gnome.gnome-panel.gschema.xml b/data/org.gnome.gnome-panel.gschema.xml
+index 08c4bbfa3..c411da8c5 100644
+--- a/data/org.gnome.gnome-panel.gschema.xml
++++ b/data/org.gnome.gnome-panel.gschema.xml
+@@ -95,27 +95,4 @@
+ </key>
+ </schema>
+
+- <schema id="org.gnome.gnome-panel.run-dialog" path="/org/gnome/gnome-panel/run-dialog/">
+- <key type="as" name="history">
+- <default>[]</default>
+- <summary>History of "Run Application" dialog</summary>
+- <description>The list of commands used in the past in the "Run Application" dialog.</description>
+- </key>
+- <key name="enable-program-list" type="b">
+- <default>true</default>
+- <summary>Enable program list in "Run Application" dialog</summary>
+- <description>If true, the "Known Applications" listing in the "Run Application" dialog is made available. Whether or not the listing is expanded when the dialog is shown is controlled by the show_program_list key.</description>
+- </key>
+- <key name="show-program-list" type="b">
+- <default>false</default>
+- <summary>Expand program list in "Run Application" dialog</summary>
+- <description>If true, the "Known Applications" listing in the "Run Application" dialog is expanded when the dialog is opened. This key is only relevant if the enable_program_list key is true.</description>
+- </key>
+- <key name="enable-autocompletion" type="b">
+- <default>true</default>
+- <summary>Enable autocompletion in "Run Application" dialog</summary>
+- <description>If true, autocompletion in the "Run Application" dialog is made available.</description>
+- </key>
+- </schema>
+-
+ </schemalist>
diff --git a/data/scalable/Makefile.am b/data/scalable/Makefile.am
index 3933b3000..3acbaa593 100644
--- a/data/scalable/Makefile.am