summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Davis2018-07-27 15:01:50 -0400
committerChristopher Davis2018-07-27 15:01:50 -0400
commit6ddb41a3d311b45f55a897f819130054711a485b (patch)
tree5ad7bdf3ab85c8cdad5b5abe38c59a085b7678e0
downloadaur-6ddb41a3d311b45f55a897f819130054711a485b.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD32
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3114f46b991
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = gnome-podcasts-git
+ pkgdesc = A Podcast Client for the GNOME Desktop written in Rust (Git version)
+ pkgver = r1267.9d64d3e
+ pkgrel = 1
+ url = https://gitlab.gnome.org/World/podcasts
+ arch = x86_64
+ license = GPL3
+ makedepends = gtk3
+ makedepends = rust
+ makedepends = pkg-config
+ makedepends = git
+ makedepends = meson
+ makedepends = git
+ depends = glib2
+ depends = openssl
+ depends = sqlite
+ depends = gtk3
+ provides = gnome-podcasts
+ conflicts = gnome-podcasts
+ conflicts = hammond
+ replaces = hammond
+ replaces = hammond-git
+ source = git+https://gitlab.gnome.org/World/podcasts.git
+ sha256sums = SKIP
+
+pkgname = gnome-podcasts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fdf70f511f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: brainblasted <brainblasted at disroot dot org>
+pkgname=gnome-podcasts-git
+pkgver=r1267.9d64d3e
+pkgrel=1
+_gitname=podcasts
+pkgdesc="A Podcast Client for the GNOME Desktop written in Rust (Git version)"
+arch=('x86_64')
+license=('GPL3')
+provides=('gnome-podcasts')
+conflicts=('gnome-podcasts' 'hammond')
+replaces=('hammond' 'hammond-git')
+url="https://gitlab.gnome.org/World/${_gitname}"
+depends=('glib2' 'openssl' 'sqlite' 'gtk3')
+makedepends=('gtk3' 'rust' 'pkg-config' 'git' 'meson' 'git')
+source=("git+https://gitlab.gnome.org/World/${_gitname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/"${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}"/"${_gitname}"
+ arch-meson . _build
+ ninja -C _build
+}
+
+package() {
+ cd "${srcdir}"/"${_gitname}"
+ DESTDIR="$pkgdir" ninja -C _build install
+}