summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuna Jernberg2022-01-30 18:32:28 +0100
committerLuna Jernberg2022-01-30 18:32:28 +0100
commit1684dd84fd9fcfc3fd3d646bbbfc0af7f84cc952 (patch)
treeb45432cb144c400072bb83354038c0f4d9ebcd88
downloadaur-1684dd84fd9fcfc3fd3d646bbbfc0af7f84cc952.tar.gz
GNOME Radio 14 init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6a6ea1ea947
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gnome-radio
+ pkgdesc = Easily find live radio programs based on geographical location of radio broadcasters on the Internet
+ pkgver = 14.0.0
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Radio
+ arch = x86_64
+ license = GPL3
+ makedepends = intltool
+ makedepends = itstool
+ makedepends = python
+ depends = libchamplain
+ depends = geoclue
+ depends = gst-plugins-base
+ depends = gst-plugins-bad
+ source = https://download.gnome.org/sources/gnome-radio/14.0/gnome-radio-14.0.0.tar.xz
+ sha256sums = f1e8aed63d12dd8a70d38ab6f7e518d4f8b54d4d548bc51d729cce0dd16e8efd
+
+pkgname = gnome-radio
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d6d06042349
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Luna Jernberg <lunajernberg@gnome.org>
+
+
+pkgname=gnome-radio
+pkgver=14.0.0
+pkgrel=1
+pkgdesc="Easily find live radio programs based on geographical location of radio broadcasters on the Internet"
+arch=('x86_64')
+url="https://wiki.gnome.org/Apps/Radio"
+license=(GPL3)
+depends=('libchamplain' 'geoclue' 'gst-plugins-base' 'gst-plugins-bad')
+makedepends=('intltool' 'itstool' 'python')
+source=(https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
+sha256sums=('f1e8aed63d12dd8a70d38ab6f7e518d4f8b54d4d548bc51d729cce0dd16e8efd')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --with-recording
+ make
+}
+
+check(){
+ cd $pkgname-$pkgver
+ make check -k
+}
+
+package(){
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+