summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcabbage2017-10-20 12:58:13 +0800
committercabbage2017-10-20 12:58:13 +0800
commit5ee6f731fa9a7de5824079d64f43e4ac3edebd6d (patch)
tree2cd44f2a9156401e458a27ae82ad6922154dca70
downloadaur-5ee6f731fa9a7de5824079d64f43e4ac3edebd6d.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0ed0200a91c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gnome-screenshot-heavy-shadow
+ pkgdesc = Take pictures of your screen, with modified shadow effect
+ pkgver = 3.25.0
+ pkgrel = 1
+ url = https://github.com/Cabbagec/gnome-screenshot-heavy-shadow
+ arch = any
+ groups = gnome
+ license = GPL2
+ makedepends = meson,
+ makedepends = appstream-glib,
+ makedepends = git
+ depends = dconf,
+ depends = gtk3,
+ depends = libcanberra
+ provides = gnome-screenshot
+ conflicts = gnome-screenshot,
+ conflicts = gnome-screenshot-git
+ source = git+https://github.com/Cabbagec/gnome-screenshot-heavy-shadow#branch=master
+ sha256sums = SKIP
+
+pkgname = gnome-screenshot-heavy-shadow
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24442e930d3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Brandon <aur at everdream.xyz>
+
+pkgname=gnome-screenshot-heavy-shadow
+pkgver=3.25.0
+pkgrel=1
+pkgdesc="Take pictures of your screen, with modified shadow effect"
+arch=('any')
+url="https://github.com/Cabbagec/gnome-screenshot-heavy-shadow"
+license=('GPL2')
+groups=('gnome')
+depends=('dconf', 'gtk3', 'libcanberra')
+makedepends=('meson', 'appstream-glib', 'git')
+provides=('gnome-screenshot')
+conflicts=('gnome-screenshot', 'gnome-screenshot-git')
+source=("git+https://github.com/Cabbagec/gnome-screenshot-heavy-shadow#branch=master")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}