summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2021-07-16 07:05:58 +0200
committerMichal Wojdyla2021-07-16 07:05:58 +0200
commit39fc75fb1d3d559eb4676f23e23a6be84c126b46 (patch)
tree28588e87f95d5a14541476fd67b0c4d103b127f7
parent2f606c3d09c6b241f1390e64070a36db8af03234 (diff)
downloadaur-gnome-search-tool-no-nautilus.tar.gz
update to latest commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
-rw-r--r--gnome-search-tool.install31
3 files changed, 42 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9b46e05643a..a41a53edea68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = gnome-search-tool-no-nautilus
- pkgdesc = installs gnome-search-tool to search for files without nautilus or gnome-desktop
- pkgver = 3.6.0
- pkgrel = 3
- url = http://gnome.org
- install = gnome-search-tool.install
- arch = i686
+ pkgdesc = Utility to search for files without nautilus or gnome-desktop
+ pkgver = 3.6.0+82+g4a8f34e
+ pkgrel = 1
+ url = https://gitlab.gnome.org/Archive/gnome-search-tool
arch = x86_64
license = GPL2
makedepends = intltool
makedepends = yelp-tools
+ makedepends = git
+ makedepends = gnome-common
depends = nautilus-data
depends = libsm
- provides = gnome-search-tool=3.6.0
+ provides = gnome-search-tool
conflicts = gnome-search-tool
- options = !emptydirs
- source = http://download.gnome.org/sources/gnome-search-tool/3.6/gnome-search-tool-3.6.0.tar.xz
- sha256sums = a33000cd7d033be4ea50422f0f2cca611da5b79bd0f0875017f105a1bc177f42
+ source = git+https://gitlab.gnome.org/Archive/gnome-search-tool.git#commit=4a8f34e050fb794852264cf54feb7d449dd15965
+ sha256sums = SKIP
pkgname = gnome-search-tool-no-nautilus
-
diff --git a/PKGBUILD b/PKGBUILD
index 1976d5fdb65c..fddcc8c1313f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
-# $Id: PKGBUILD 183396 2013-04-21 22:10:19Z heftig $
-# Maintainer: Colin Keenan <colinnkeenan at gmail dot com>
+# Contributor: Colin Keenan <colinnkeenan at gmail dot com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# The difference between this PKGBUILD and the one for gnome-search-tool is "depends..."
@@ -7,30 +6,46 @@
# It depends on nautilus-data instead, also available in AUR, and so avoids gnome-desktop
pkgname=gnome-search-tool-no-nautilus
-pkgver=3.6.0
-pkgrel=3
-pkgdesc="installs gnome-search-tool to search for files without nautilus or gnome-desktop"
-arch=(i686 x86_64)
-url="http://gnome.org"
-license=('GPL2')
-depends=('nautilus-data' 'libsm')
-makedepends=('intltool' 'yelp-tools')
-provides=('gnome-search-tool=3.6.0')
-install=gnome-search-tool.install
+pkgver=3.6.0+82+g4a8f34e
+pkgrel=1
+pkgdesc="Utility to search for files without nautilus or gnome-desktop"
+arch=(x86_64)
+url="https://gitlab.gnome.org/Archive/gnome-search-tool"
+license=(GPL2)
+depends=(nautilus-data libsm)
+makedepends=(intltool yelp-tools git gnome-common)
+provides=('gnome-search-tool')
conflicts=('gnome-search-tool')
-options=('!emptydirs')
-source=(http://download.gnome.org/sources/gnome-search-tool/${pkgver%.*}/gnome-search-tool-$pkgver.tar.xz)
-sha256sums=('a33000cd7d033be4ea50422f0f2cca611da5b79bd0f0875017f105a1bc177f42')
+_commit=4a8f34e050fb794852264cf54feb7d449dd15965 # master
+source=("git+https://gitlab.gnome.org/Archive/gnome-search-tool.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gnome-search-tool
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd gnome-search-tool
+
+ # Fix configure
+ sed -i '/^AM_GNU_GETTEXT/d' configure.ac
+
+ NOCONFIGURE=1 ./autogen.sh
+}
build() {
- cd "gnome-search-tool-$pkgver"
+ cd gnome-search-tool
./configure --prefix=/usr --sysconfdir=/etc
make
}
+check() {
+ make -C gnome-search-tool check
+}
+
package() {
- cd "gnome-search-tool-$pkgver"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make -C gnome-search-tool install
}
# vim:set ts=2 sw=2 et:
diff --git a/gnome-search-tool.install b/gnome-search-tool.install
deleted file mode 100644
index 0faafb370dfe..000000000000
--- a/gnome-search-tool.install
+++ /dev/null
@@ -1,31 +0,0 @@
-# Some colored makepkg-like functions
-msg_blue() {
- printf "${BLUE}==>${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
-}
-
-note() {
- printf "${BLUE}==>${ALL_OFF}${YELLOW} NOTE:${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
-}
-
-ALL_OFF="$(tput sgr0)"
-BOLD="$(tput bold)"
-BLUE="${BOLD}$(tput setaf 4)"
-YELLOW="${BOLD}$(tput setaf 3)"
-
-post_install() {
- glib-compile-schemas usr/share/glib-2.0/schemas
- note "The command is just 'gnome-search-tool' (without '-no-nautilus')"
-}
-
-pre_upgrade() {
- (( $(vercmp $2 3.6.0) < 0 )) && gconfpkg --uninstall gnome-search-tool
- return 0
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}