summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-03-27 11:03:40 -0600
committerMark Wagie2023-03-27 11:03:40 -0600
commitfcab22a3338d0e0316b3c090670fc027da1a7c86 (patch)
tree30cd9e09a42c20881008cbf012b316be8653799e
parenta74479b289f6cbce46621331cc9db757bd2e5c7e (diff)
downloadaur-fcab22a3338d0e0316b3c090670fc027da1a7c86.tar.gz
3.10.1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--0002-Fix-GTK-3.14-incompatibilities.patch56
-rw-r--r--PKGBUILD19
4 files changed, 74 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af32e45a2462..667e3e1c8150 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-session-properties
pkgdesc = The GNOME Session Properties Tool
- pkgver = 3.10.0
- pkgrel = 4
+ pkgver = 3.10.1
+ pkgrel = 1
url = https://www.gnome.org
arch = x86_64
license = GPL2
@@ -11,11 +11,11 @@ pkgbase = gnome-session-properties
depends = gtk3
depends = hicolor-icon-theme
depends = dbus-glib
- source = https://download-fallback.gnome.org/sources/gnome-session/3.10/gnome-session-3.10.0.tar.xz
- source = https://raw.githubusercontent.com/chenxiaolong/AUR-Files/b8632ea084b21e5fdef70a5ba7787c5567403146/gnome-session-properties/0001-Remove-unneeded-stuff.patch
- source = https://raw.githubusercontent.com/chenxiaolong/AUR-Files/b8632ea084b21e5fdef70a5ba7787c5567403146/gnome-session-properties/0002-Fix-GTK-3.14-incompatibilities.patch
- sha256sums = 38d90c5d5a33ec8a3002f1e77e201c1554eeb8bbba8923d94fab81b3a8e0696e
- sha256sums = 8ded70b5567ffef768300af496f2d8b7544b2adae707ca7e5592e87670af8730
+ source = https://download-fallback.gnome.org/sources/gnome-session/3.10/gnome-session-3.10.1.tar.xz
+ source = https://raw.githubusercontent.com/yochananmarqos/pkgbuilds/master/gnome-session-properties/0001-Remove-unneeded-stuff.patch
+ source = 0002-Fix-GTK-3.14-incompatibilities.patch
+ sha256sums = f620704e07e6bbf49aa6c65897475a46f80f7ac5593606f2b6889c7cb4f6a9cc
+ sha256sums = 4a064778dbbd235322bbbefd086ea7653679a0714230ebcac772eab373d83991
sha256sums = a06118f85b26ef13d82f666f8a86cae1fb3e9ca12cd45703ef4dd9ecadfa3aab
pkgname = gnome-session-properties
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..e2aed964e769 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!0002-Fix-GTK-3.14-incompatibilities.patch
diff --git a/0002-Fix-GTK-3.14-incompatibilities.patch b/0002-Fix-GTK-3.14-incompatibilities.patch
new file mode 100644
index 000000000000..790b68dbc97b
--- /dev/null
+++ b/0002-Fix-GTK-3.14-incompatibilities.patch
@@ -0,0 +1,56 @@
+From fde630356c1ec89d996f8a68d770dd499cab7e90 Mon Sep 17 00:00:00 2001
+From: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+Date: Sat, 1 Nov 2014 13:52:02 -0400
+Subject: [PATCH 2/2] Fix GTK 3.14 incompatibilities
+
+---
+ capplet/gsm-app-dialog.c | 6 ++++++
+ capplet/gsm-properties-dialog.c | 2 ++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/capplet/gsm-app-dialog.c b/capplet/gsm-app-dialog.c
+index e7369dd..b072d10 100644
+--- a/capplet/gsm-app-dialog.c
++++ b/capplet/gsm-app-dialog.c
+@@ -179,10 +179,14 @@ setup_dialog (GsmAppDialog *dialog)
+ gtk_container_set_border_width (GTK_CONTAINER (dialog), 6);
+ gtk_window_set_icon_name (GTK_WINDOW (dialog), "session-properties");
+
++#if !GTK_CHECK_VERSION (3, 14, 0)
+ g_object_set (dialog,
+ "allow-shrink", FALSE,
+ "allow-grow", FALSE,
+ NULL);
++#else
++ gtk_window_set_resizable (GTK_WINDOW (dialog), FALSE);
++#endif
+
+ gtk_dialog_add_button (GTK_DIALOG (dialog),
+ GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL);
+@@ -250,7 +254,9 @@ gsm_app_dialog_constructor (GType type,
+
+ setup_dialog (dialog);
+
++#if !GTK_CHECK_VERSION (3, 14, 0)
+ gtk_widget_show_all (GTK_WIDGET (dialog));
++#endif
+
+ return G_OBJECT (dialog);
+ }
+diff --git a/capplet/gsm-properties-dialog.c b/capplet/gsm-properties-dialog.c
+index 24bf907..81f26da 100644
+--- a/capplet/gsm-properties-dialog.c
++++ b/capplet/gsm-properties-dialog.c
+@@ -659,7 +659,9 @@ gsm_properties_dialog_constructor (GType type,
+
+ setup_dialog (dialog);
+
++#if !GTK_CHECK_VERSION (3, 14, 0)
+ gtk_widget_show (GTK_WIDGET (dialog));
++#endif
+
+ return G_OBJECT (dialog);
+ }
+--
+2.1.3
+
diff --git a/PKGBUILD b/PKGBUILD
index 067fc884bdfe..190aba827d58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
pkgname=gnome-session-properties
-pkgver=3.10.0
-pkgrel=4
+pkgver=3.10.1
+pkgrel=1
pkgdesc="The GNOME Session Properties Tool"
arch=('x86_64')
url="https://www.gnome.org"
@@ -10,16 +10,17 @@ license=('GPL2')
depends=('gtk3' 'hicolor-icon-theme' 'dbus-glib')
makedepends=('gnome-common' 'gtk-doc' 'intltool')
source=("https://download-fallback.gnome.org/sources/gnome-session/${pkgver%.*}/gnome-session-${pkgver}.tar.xz"
- 'https://raw.githubusercontent.com/chenxiaolong/AUR-Files/b8632ea084b21e5fdef70a5ba7787c5567403146/gnome-session-properties/0001-Remove-unneeded-stuff.patch'
- 'https://raw.githubusercontent.com/chenxiaolong/AUR-Files/b8632ea084b21e5fdef70a5ba7787c5567403146/gnome-session-properties/0002-Fix-GTK-3.14-incompatibilities.patch')
-sha256sums=('38d90c5d5a33ec8a3002f1e77e201c1554eeb8bbba8923d94fab81b3a8e0696e'
- '8ded70b5567ffef768300af496f2d8b7544b2adae707ca7e5592e87670af8730'
+ # Patch too large to upload to aurweb
+ 'https://raw.githubusercontent.com/yochananmarqos/pkgbuilds/master/gnome-session-properties/0001-Remove-unneeded-stuff.patch'
+ '0002-Fix-GTK-3.14-incompatibilities.patch')
+sha256sums=('f620704e07e6bbf49aa6c65897475a46f80f7ac5593606f2b6889c7cb4f6a9cc'
+ '4a064778dbbd235322bbbefd086ea7653679a0714230ebcac772eab373d83991'
'a06118f85b26ef13d82f666f8a86cae1fb3e9ca12cd45703ef4dd9ecadfa3aab')
prepare() {
cd "gnome-session-${pkgver}"
- patch -p1 -i ../0001-Remove-unneeded-stuff.patch
- patch -p1 -i ../0002-Fix-GTK-3.14-incompatibilities.patch
+ patch -Np1 -i ../0001-Remove-unneeded-stuff.patch
+ patch -Np1 -i ../0002-Fix-GTK-3.14-incompatibilities.patch
# Fix icon
sed -ri '/^Icon/ s/session-/gnome-session-/g' \