summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpriponne2015-09-05 22:12:11 +0200
committerpriponne2015-09-05 22:12:11 +0200
commit60484e2005c5864d2f6c0475c3bdebcbe4ecc99d (patch)
treeebb8653cfa9b7b8f99b5e3e3225941b43a975905
downloadaur-60484e2005c5864d2f6c0475c3bdebcbe4ecc99d.tar.gz
Initial import
-rw-r--r--.SRCINFO42
-rw-r--r--120dpi.patch13
-rw-r--r--PKGBUILD42
-rw-r--r--gnome-settings-daemon.install12
4 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fd8c2d3743b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = gnome-settings-daemon-120dpi
+ pkgdesc = This version of the GNOME Settings changes dpi settings to 120 dpi (from the default value of 96)
+ pkgver = 3.16.3
+ pkgrel = 1
+ url = http://www.gnome.org
+ install = gnome-settings-daemon.install
+ arch = i686
+ arch = x86_64
+ groups = gnome
+ license = GPL
+ makedepends = intltool
+ makedepends = xf86-input-wacom
+ makedepends = libxslt
+ makedepends = docbook-xsl
+ makedepends = python2
+ depends = dconf
+ depends = gnome-desktop
+ depends = gsettings-desktop-schemas
+ depends = hicolor-icon-theme
+ depends = libcanberra-pulse
+ depends = libnotify
+ depends = libsystemd
+ depends = libwacom
+ depends = pulseaudio
+ depends = pulseaudio-alsa
+ depends = upower
+ depends = librsvg
+ depends = libgweather
+ depends = geocode-glib
+ depends = geoclue2
+ depends = nss
+ depends = libgudev
+ provides = gnome-settings-daemon
+ conflicts = gnome-settings-daemon
+ options = !emptydirs
+ source = http://ftp.gnome.org/pub/gnome/sources/gnome-settings-daemon/3.16/gnome-settings-daemon-3.16.3.tar.xz
+ source = 120dpi.patch
+ sha256sums = 8752f79ba2ee76701744b4806140d1b88c665ad7cd44e7ff58b4e78e1063daea
+ sha256sums = ad32314bb0251298290f4f739be9fe278d498723856248ce4956044b17db4cfa
+
+pkgname = gnome-settings-daemon-120dpi
+
diff --git a/120dpi.patch b/120dpi.patch
new file mode 100644
index 000000000000..c400b9b85015
--- /dev/null
+++ b/120dpi.patch
@@ -0,0 +1,13 @@
+diff --git a/plugins/xsettings/gsd-xsettings-manager.c b/plugins/xsettings/gsd-xsettings-manager.c
+index 5b3a866..e57d168 100644
+--- a/plugins/xsettings/gsd-xsettings-manager.c
++++ b/plugins/xsettings/gsd-xsettings-manager.c
+@@ -228,7 +228,7 @@
+ * - ajax
+ *
+ */
+-#define DPI_FALLBACK 96
++#define DPI_FALLBACK 120
+
+ /* The minimum resolution at which we turn on a window-scale of 2 */
+ #define HIDPI_LIMIT (DPI_FALLBACK * 2)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8e73ac2f03f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id$
+# Maintainer: Kresimir Pripuzic <kpripuzic@gmail.com>
+
+pkgname=gnome-settings-daemon-120dpi
+pkgver=3.16.3
+pkgrel=1
+pkgdesc="This version of the GNOME Settings changes dpi settings to 120 dpi (from the default value of 96)"
+arch=(i686 x86_64)
+license=(GPL)
+depends=(dconf gnome-desktop gsettings-desktop-schemas hicolor-icon-theme libcanberra-pulse
+ libnotify libsystemd libwacom pulseaudio pulseaudio-alsa upower librsvg libgweather
+ geocode-glib geoclue2 nss libgudev)
+makedepends=(intltool xf86-input-wacom libxslt docbook-xsl python2)
+options=('!emptydirs')
+install=gnome-settings-daemon.install
+url="http://www.gnome.org"
+groups=(gnome)
+provides=('gnome-settings-daemon')
+conflicts=('gnome-settings-daemon')
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname:0:21}/${pkgver:0:4}/${pkgname:0:21}-$pkgver.tar.xz
+ 120dpi.patch)
+sha256sums=('8752f79ba2ee76701744b4806140d1b88c665ad7cd44e7ff58b4e78e1063daea'
+ 'ad32314bb0251298290f4f739be9fe278d498723856248ce4956044b17db4cfa')
+
+build() {
+ cd ${pkgname:0:21}-$pkgver
+
+ patch -Np1 -i ../120dpi.patch
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --libexecdir=/usr/lib/${pkgname:0:21} --disable-static
+
+ #https://bugzilla.gnome.org/show_bug.cgi?id=656231
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd ${pkgname:0:21}-$pkgver
+ make DESTDIR="$pkgdir" install
+}
diff --git a/gnome-settings-daemon.install b/gnome-settings-daemon.install
new file mode 100644
index 000000000000..f7e8c46ac846
--- /dev/null
+++ b/gnome-settings-daemon.install
@@ -0,0 +1,12 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}