summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMárcio2021-02-12 23:52:13 -0300
committerMárcio2021-02-12 23:52:13 -0300
commit3ac9dc5d37899e18bddd0fa2592f8ac771833599 (patch)
tree0664a714b6b98e95a0e35d065463341872c3564c
parent2ab375173f7bdfc6c535fb6d8fac1f33ffc1e200 (diff)
downloadaur-3ac9dc5d37899e18bddd0fa2592f8ac771833599.tar.gz
Update to git source
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f26f7783a8df..a3f31b347231 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-40alfa
pkgdesc = Next generation desktop shell
- pkgver = 40.1.20210208.2
+ pkgver = 40.alpha.1.1+228+g829a096ba
pkgrel = 1
epoch = 1
url = https://gitlab.gnome.org/GNOME/gnome-shell
@@ -46,8 +46,10 @@ pkgbase = gnome-shell-40alfa
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
conflicts = gnome-shell
- source = https://gitlab.gnome.org/haecker-felix/gnome-shell-40-copr/uploads/3551d83ba16b5048dd62448989722061/gnome-shell.tar.xz
- sha256sums = d02f52dffd86365e1d28bf8aa2694ea818d168324512b163fe68cf0df4bc9fec
+ options = debug
+ options = !strip
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git
+ sha256sums = SKIP
pkgname = gnome-shell-40alfa
diff --git a/PKGBUILD b/PKGBUILD
index 6d6c19db892d..382fa0fa3863 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=gnome-shell-40alfa
_pkgname=gnome-shell
-pkgver=40.1.20210208.2
+pkgver=40.alpha.1.1+228+g829a096ba
pkgrel=1
epoch=1
pkgdesc="Next generation desktop shell"
@@ -13,23 +13,31 @@ depends=(accountsservice gcr gjs js78 gnome-bluetooth upower gnome-session
gnome-settings-daemon sysprof gnome-themes-extra
gsettings-desktop-schemas-git gtk4 libcanberra-pulse libcroco
libgdm libgweather-git libsecret mutter-40alfa nm-connection-editor
- unzip gstreamer libibus gnome-desktop bash-completion gnome-autoar glib2-git)
+ unzip gstreamer libibus gnome-desktop bash-completion gnome-autoar
+ glib2-git)
-makedepends=(gtk-doc gnome-control-center evolution-data-server gobject-introspection git meson
- sassc asciidoc vulkan-headers)
+makedepends=(gtk-doc gnome-control-center evolution-data-server
+ gobject-introspection git meson sassc asciidoc vulkan-headers)
+
optdepends=('gnome-control-center: System settings'
'evolution-data-server: Evolution calendar integration')
+
groups=(gnome)
provides=(gnome-shell)
conflicts=(gnome-shell)
+options=(debug !strip)
-source=("https://gitlab.gnome.org/haecker-felix/gnome-shell-40-copr/uploads/3551d83ba16b5048dd62448989722061/gnome-shell.tar.xz")
+source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git")
-sha256sums=('d02f52dffd86365e1d28bf8aa2694ea818d168324512b163fe68cf0df4bc9fec')
+sha256sums=('SKIP')
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
build() {
- arch-meson "$_pkgname" build -D gtk_doc=true
+ arch-meson "$_pkgname" build -D gtk_doc=false
ninja -C build
}