summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-11-01 13:59:15 +0100
committerXZS2016-11-01 13:59:15 +0100
commitc6d95e4fc677a208ee9293ebab3d0d0edab4d8cb (patch)
tree82df6b26a8d50eaee88cdc4a51f4a0795d53104e
parent07f916c19655e2d52de90cc623391b2753f985e3 (diff)
downloadaur-c6d95e4fc677a208ee9293ebab3d0d0edab4d8cb.tar.gz
choose newest extension source
Some extensions authors introduce build steps required before installing. Their execution normally produces a completed variant of the extension code in a subdirectory, difficult to tell apart from the original source. The find condition introduced herein proves the process against such cases to come. It always chooses the files created last, ensuring that a build which occurred after mere unpacking will always take precedence.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91ac2a778e19..741b1ac2ed2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,7 +55,8 @@ package() {
}
package_01_locate() {
msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; -printf %h -quit)"
+ cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
+ -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
}