summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-07-20 16:02:46 +0200
committerXZS2016-07-20 16:02:46 +0200
commitc72bcd93f019b02b57c5397d2d4fe1bc723bcb7b (patch)
tree546ae1f02313073574c69e27ff5799a6bb9d65fc
parent991fa6c969f60658856a868442c126cb5e4e8c69 (diff)
downloadaur-c72bcd93f019b02b57c5397d2d4fe1bc723bcb7b.tar.gz
break long lines
According to the Arch Packaging Standards [1], lines in a PKGBUILD should be no longer than 100 characters and package descriptions should cap at 80. This does not change the contents of the built package, so the pkgver stays unchanged. [1]: https://wiki.archlinux.org/index.php/Arch_packaging_standards
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59e73eee2691..bc26a533815b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = gnome-shell-extension-activities-config
- pkgdesc = Configure the Activities Button with the Activities Configurator Extension and the Gnome Shell Extension Preferences Tool.
+ pkgdesc = Configure the Activities Button via the Gnome Shell Extension Preferences Tool.
pkgver = 44
pkgrel = 1
url = https://extensions.gnome.org/extension/358/activities-configurator/
diff --git a/PKGBUILD b/PKGBUILD
index e6e54f8d27b1..a33169c61384 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=gnome-shell-extension-activities-config
pkgver=44
pkgrel=1
-pkgdesc="Configure the Activities Button with the Activities Configurator Extension and the Gnome Shell Extension Preferences Tool."
+pkgdesc="Configure the Activities Button via the Gnome Shell Extension Preferences Tool."
arch=(any)
url="https://extensions.gnome.org/extension/358/activities-configurator/"
license=(GPLv2)
@@ -18,7 +18,8 @@ find_version() {
if [ ! -d version ]; then
grep -Po '(?<=data-svm=").*(?=")' extension.html | # extract version information
sed 's/&quot;/"/g' | # unescape quotes
- sed 's/[{ ,]*"[[:digit:].]\+": {"pk": \([[:digit:]]\+\), "version": \([[:digit:]]\+\)}[ ,}]*/\2 \1\n/g' | # list one version per line
+ sed 's/[{ ,]*"[[:digit:].]\+": {"pk": \([[:digit:]]\+\),'$(
+ )' "version": \([[:digit:]]\+\)}[ ,}]*/\2 \1\n/g' | # list one version per line
sort -nr | head -n1 | tr ' ' '\n' > version # get newest and write
fi
}
@@ -61,7 +62,8 @@ package_01_locate() {
package_02_install() {
msg2 'Installing extension code...'
- find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) -exec install -Dm644 -t "$destdir" '{}' +
+ find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) \
+ -exec install -Dm644 -t "$destdir" '{}' +
}
depends+=(gnome-shell-extensions)