summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2015-08-18 16:56:52 +0200
committerXZS2015-08-18 16:56:52 +0200
commit60ffc547ec190efaf4004881fdd6bc7accb282b4 (patch)
treedef867654f839dbb1f386bb665a9c8c854db032d
downloadaur-60ffc547ec190efaf4004881fdd6bc7accb282b4.tar.gz
initial import from old AUR version 3
The package was missing its -git suffix there which had been fixed here.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af18a38303ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = gnome-shell-extension-aggregatemenu-hider-git
+ pkgdesc = A generator for Gnome Shell extensions that hide items from the aggregate menu.
+ pkgver = 3
+ pkgrel = 2
+ url = https://github.com/dffischer/gnome-aggregatemenu-hider
+ arch = any
+ license = GPLv3
+ makedepends = waf
+ depends = gnome-shell
+ source = gnome-shell-extension-aggregatemenu-hider-git::git://github.com/dffischer/gnome-aggregatemenu-hider.git
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-hide-brightness-git
+ pkgdesc = Hides the brightness slider from the aggregate menu
+
+pkgname = gnome-shell-extension-hide-volume-git
+ pkgdesc = Hides the volume controls from the aggregate menu. The volume can still be adjusted via hardware keys
+
+pkgname = gnome-shell-extension-hide-user-git
+ pkgdesc = Hides the switch user sub menu from the aggregated menu, removing the logout option. Handy for a single-user system
+
+pkgname = gnome-shell-extension-hide-location-git
+ pkgdesc = Hides the location options from the aggregate menu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70d1a3a449d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: XZS <d.f.fischer at web dot de>
+
+# To only build some of the extensions, remove
+# the unwanted ones from the $extensions variable.
+extensions=('brightness' 'volume' 'user' 'location')
+pkgbase='gnome-shell-extension-aggregatemenu-hider-git'
+for e in ${extensions[@]}; do
+ local pkg=gnome-shell-extension-hide-$e-git
+ pkgname+=($pkg)
+ eval "package_${pkg}() {
+ package ${e^*}
+ }"
+done
+
+pkgdesc="A generator for Gnome Shell extensions that hide items from the aggregate menu."
+pkgver=3
+pkgrel=2
+arch=(any)
+url='https://github.com/dffischer/gnome-aggregatemenu-hider'
+license=(GPLv3)
+depends=('gnome-shell')
+makedepends=('waf')
+source=("$pkgbase::git://github.com/dffischer/gnome-aggregatemenu-hider.git")
+md5sums=('SKIP')
+
+build() {
+ join() {
+ local IFS="$1"; shift; echo "$*";
+ }
+ cd $pkgbase
+ waf --prefix=/usr configure
+ waf --targets=$(join , ${extensions[@]^*}) build
+}
+
+package() {
+ cd $pkgbase
+ waf --destdir="$pkgdir" --targets=$1 install
+ pkgdesc=\
+"$(grep -Po '(?<="description": ").*(?=")' build/hide-$1@*/metadata.json)"
+}