summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-04-08 17:54:31 +0300
committerIgor Dyatlov2022-04-08 17:54:31 +0300
commit398985ff0638a31972594e74815337dcef25e682 (patch)
tree52898736388f12048224c1c1a5773f4405ac5b64
parent6b60efd5fd8cfa77491f3f86e4ed66b928efd722 (diff)
downloadaur-398985ff0638a31972594e74815337dcef25e682.tar.gz
Updates
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78a549a0570b..82c26c9b00e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = gnome-shell-extension-alphabetical-grid-extension-git
pkgdesc = Restore the alphabetical ordering of the app grid, removed in GNOME 3.38
- pkgver = 17.0.r0.g7594ebd
+ pkgver = 22.0.r0.g557d442
pkgrel = 1
url = https://github.com/stuarthayhurst/alphabetical-grid-extension
arch = any
license = GPL3
makedepends = git
- makedepends = zip
- depends = gnome-shell>=3.38
+ depends = gnome-shell
provides = gnome-shell-extension-alphabetical-grid-extension
conflicts = gnome-shell-extension-alphabetical-grid-extension
source = git+https://github.com/stuarthayhurst/alphabetical-grid-extension.git
- sha256sums = SKIP
+ b2sums = SKIP
pkgname = gnome-shell-extension-alphabetical-grid-extension-git
diff --git a/PKGBUILD b/PKGBUILD
index af0037fc6bd5..690f2965c2e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=gnome-shell-extension-alphabetical-grid-extension-git
-pkgver=17.0.r0.g7594ebd
+pkgver=22.0.r0.g557d442
pkgrel=1
-pkgdesc="Restore the alphabetical ordering of the app grid, removed in GNOME 3.38 "
+pkgdesc="Restore the alphabetical ordering of the app grid, removed in GNOME 3.38"
arch=('any')
url="https://github.com/stuarthayhurst/alphabetical-grid-extension"
license=('GPL3')
-depends=('gnome-shell>=3.38')
-makedepends=('git' 'zip')
+depends=('gnome-shell')
+makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(git+$url.git)
_source=alphabetical-grid-extension
-sha256sums=('SKIP')
+b2sums=('SKIP')
pkgver() {
cd "$srcdir/${_source}"
@@ -22,17 +22,18 @@ pkgver() {
build() {
cd "$srcdir/${_source}"
- make build
+ make package
}
package() {
_uuid='AlphabeticalAppGrid@stuarthayhurst'
- _install_dir="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
- install -d ${_install_dir}
cd "$srcdir/${_source}"
- bsdtar xvf ${_uuid}.shell-extension.zip -C ${_install_dir}
- install -Dm644 "schemas/org.gnome.shell.extensions.AlphabeticalAppGrid.gschema.xml" -t "${pkgdir}/usr/share/glib-2.0/schemas/"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
+ bsdtar xvf "$_uuid.shell-extension.zip" -C "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/"
+ install -Dm644 "extension/schemas/org.gnome.shell.extensions.AlphabeticalAppGrid.gschema.xml" -t \
+ "$pkgdir/usr/share/glib-2.0/schemas/"
- install -Dm644 "LICENSE.txt" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ rm -rf "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/schemas/"
+ rm "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/LICENSE.txt"
}