summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-09-03 16:56:03 +0300
committerIgor Dyatlov2021-09-03 16:56:03 +0300
commitda2d83f6f32c6a6e3de31b91e22eca3076cb91e8 (patch)
treeed86b5542b12519a6e33c2bbed45b6521292b9d6
downloadaur-da2d83f6f32c6a6e3de31b91e22eca3076cb91e8.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71bd270af9b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-alphabetical-grid-extension-git
+ pkgdesc = Restore the alphabetical ordering of the app grid, removed in GNOME 3.38
+ pkgver = v12.0.r40.g21bfe43
+ pkgrel = 1
+ url = https://github.com/stuarthayhurst/alphabetical-grid-extension
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = zip
+ depends = gnome-shell>=3.38
+ provides = gnome-shell-extension-alphabetical-grid-extension
+ conflicts = gnome-shell-extension-alphabetical-grid-extension
+ source = git+https://github.com/stuarthayhurst/alphabetical-grid-extension.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-alphabetical-grid-extension-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f040a0c84b8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=gnome-shell-extension-alphabetical-grid-extension-git
+pkgver=v12.0.r40.g21bfe43
+pkgrel=1
+pkgdesc="Restore the alphabetical ordering of the app grid, removed in GNOME 3.38 "
+arch=('any')
+url="https://github.com/stuarthayhurst/alphabetical-grid-extension"
+license=('GPL3')
+depends=('gnome-shell>=3.38')
+makedepends=('git' 'zip')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git)
+_source=alphabetical-grid-extension
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_source}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_source}"
+ make build
+}
+
+package() {
+ _uuid='AlphabeticalAppGrid@stuarthayhurst'
+ _install_dir="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+
+ install -d ${_install_dir}
+ cd "$srcdir/${_source}"
+ unzip ${_uuid}.shell-extension.zip -d ${_install_dir}
+ install -Dm644 "schemas/org.gnome.shell.extensions.AlphabeticalAppGrid.gschema.xml" -t "${pkgdir}/usr/share/glib-2.0/schemas/"
+
+ install -Dm644 "LICENSE.txt" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}