summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2019-03-04 09:22:01 +0300
committersurefire2019-03-04 09:22:01 +0300
commit7c2515a6851ad181c9e8ffd39eb69d81fb05ce49 (patch)
treed6c250b560b7949d10a36cf53303004430dc4e41
downloadaur-7c2515a6851ad181c9e8ffd39eb69d81fb05ce49.tar.gz
Initial
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8bbfc3738ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-appindicator
+ pkgdesc = Integrates AppIndicators into GNOME Shell
+ pkgver = 22
+ pkgrel = 1
+ url = https://github.com/ubuntu/gnome-shell-extension-appindicator
+ arch = any
+ license = GPL
+ depends = gnome-shell
+ optdepends = libappindicator-gtk2: support GTK+2 applications
+ optdepends = libappindicator-gtk3: support GTK+3 applications
+ optdepends = libappindicator-sharp: support .net applications
+ source = gnome-shell-extension-appindicator-22.tar.gz::https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v22.tar.gz
+ sha256sums = 1e651243b8873a5a0faa2e61722da4a3292668b04a53c0942adc9e59c69bc5c0
+
+pkgname = gnome-shell-extension-appindicator
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ba4cbaf71a5e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00962f351843
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=gnome-shell-extension-appindicator
+pkgver=22
+pkgrel=1
+pkgdesc="Integrates AppIndicators into GNOME Shell"
+arch=('any')
+url="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+license=('GPL')
+depends=('gnome-shell')
+optdepends=(
+ 'libappindicator-gtk2: support GTK+2 applications'
+ 'libappindicator-gtk3: support GTK+3 applications'
+ 'libappindicator-sharp: support .net applications'
+)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('1e651243b8873a5a0faa2e61722da4a3292668b04a53c0942adc9e59c69bc5c0')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ local _uuid="appindicatorsupport@rgcjonas.gmail.com"
+ local _destdir="${pkgdir}/usr/share/gnome-shell/extensions/$_uuid"
+
+ install -d "$_destdir"
+ cp --parents -t "$_destdir" metadata.json *.js interfaces-xml/*.xml
+}