summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2018-03-03 20:36:59 +0300
committersurefire2018-03-03 20:36:59 +0300
commit0b39b82715371064c2a85729dbfedfb8d1de14f7 (patch)
treec6e88873797420e427abfa9634b5057484737e99
parent84b97b65c72d1959e2d91a570ef9f45d521fd5c7 (diff)
downloadaur-0b39b82715371064c2a85729dbfedfb8d1de14f7.tar.gz
patch merged into upsteram
-rw-r--r--.SRCINFO6
-rw-r--r--6091a31f4cb8732252279e802c8ec9f1c3891b38.patch31
-rw-r--r--PKGBUILD18
3 files changed, 8 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13a46936584a..96839b01a536 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-appindicator-git
pkgdesc = Integrates AppIndicators into GNOME Shell.
- pkgver = 21+2+g7863517
+ pkgver = 21+4+gcce5579
pkgrel = 1
epoch = 1
url = https://github.com/ubuntu/gnome-shell-extension-appindicator
@@ -11,10 +11,10 @@ pkgbase = gnome-shell-extension-appindicator-git
optdepends = libappindicator-gtk2: support GTK+2 applications
optdepends = libappindicator-gtk3: support GTK+3 applications
optdepends = libappindicator-sharp: support .net applications
+ provides = gnome-shell-extension-appindicator
+ conflicts = gnome-shell-extension-appindicator
source = gnome-shell-extension-appindicator-git::git+https://github.com/ubuntu/gnome-shell-extension-appindicator.git
- source = 6091a31f4cb8732252279e802c8ec9f1c3891b38.patch
sha512sums = SKIP
- sha512sums = fb3375e505b030b9264cf5636468c20248cdfc967746b1f8b284b9769a678ffbad9f5e52b5481961d4dc142517c5b709a500781f50763d15d882f66ac4c9f7b8
pkgname = gnome-shell-extension-appindicator-git
diff --git a/6091a31f4cb8732252279e802c8ec9f1c3891b38.patch b/6091a31f4cb8732252279e802c8ec9f1c3891b38.patch
deleted file mode 100644
index 69bc5aad3b8f..000000000000
--- a/6091a31f4cb8732252279e802c8ec9f1c3891b38.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 6091a31f4cb8732252279e802c8ec9f1c3891b38 Mon Sep 17 00:00:00 2001
-From: Romeo Calota <kicsyromy@gmail.com>
-Date: Mon, 25 Dec 2017 15:20:25 +0200
-Subject: [PATCH] Issue #110: Fix icons vertically stretched
-
----
- appIndicator.js | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/appIndicator.js b/appIndicator.js
-index fe629c2..46f01eb 100644
---- a/appIndicator.js
-+++ b/appIndicator.js
-@@ -227,7 +227,7 @@ var IconActor = new Lang.Class({
- this.height = icon_size * scale_factor
-
- this._indicator = indicator
-- this._iconSize = icon_size * scale_factor
-+ this._iconSize = icon_size
- this._iconCache = new IconCache.IconCache()
-
- this._mainIcon = new St.Bin()
-@@ -335,6 +335,8 @@ var IconActor = new Lang.Class({
- },
-
- _createIconFromPixmap: function(iconSize, iconPixmapArray) {
-+ let scale_factor = St.ThemeContext.get_for_stage(global.stage).scale_factor;
-+ iconSize = iconSize * scale_factor
- // the pixmap actually is an array of pixmaps with different sizes
- // we use the one that is smaller or equal the iconSize
-
diff --git a/PKGBUILD b/PKGBUILD
index dbb6d8137af3..eb7490b947c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,14 @@
# Contributor: Surefire <surefire at cryptomile.net>
pkgname=gnome-shell-extension-appindicator-git
-pkgver=21+2+g7863517
+pkgver=21+4+gcce5579
pkgrel=1
epoch=1
pkgdesc="Integrates AppIndicators into GNOME Shell."
arch=('any')
url="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+conflicts=('gnome-shell-extension-appindicator')
+provides=('gnome-shell-extension-appindicator')
license=('GPL')
makedepends=('git')
depends=('gnome-shell')
@@ -18,23 +20,14 @@ optdepends=(
'libappindicator-gtk3: support GTK+3 applications'
'libappindicator-sharp: support .net applications'
)
-source=(
- "${pkgname}::git+https://github.com/ubuntu/gnome-shell-extension-appindicator.git"
- '6091a31f4cb8732252279e802c8ec9f1c3891b38.patch'
-)
-sha512sums=('SKIP'
- 'fb3375e505b030b9264cf5636468c20248cdfc967746b1f8b284b9769a678ffbad9f5e52b5481961d4dc142517c5b709a500781f50763d15d882f66ac4c9f7b8')
+source=("${pkgname}::git+https://github.com/ubuntu/gnome-shell-extension-appindicator.git")
+sha512sums=('SKIP')
pkgver() {
cd "${pkgname}"
git describe --long --tags | sed 's/^v//;s/-/+/g'
}
-prepare() {
- cd "${pkgname}"
- patch -Np1 -i "${srcdir}/6091a31f4cb8732252279e802c8ec9f1c3891b38.patch"
-}
-
package() {
cd "${pkgname}"
# Locate the extension.
@@ -44,5 +37,4 @@ package() {
# Copy extension files into place.
install -Dm644 -t "${_destdir}" ./*.js metadata.json
install -Dm644 -t "${_destdir}/interfaces-xml" ./interfaces-xml/*.xml
- install -Dm644 -t "${pkgdir}/usr/share/glib-2.0/schemas" ./interfaces-xml/*.xml
}