summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2018-02-05 11:18:36 +0300
committersurefire2018-02-05 11:18:36 +0300
commit84b97b65c72d1959e2d91a570ef9f45d521fd5c7 (patch)
tree4d859cb6087a257d14b46284e780254ed3ffe234
parent5d9928c6298488f3b77ac9a68865899cab46ed43 (diff)
downloadaur-84b97b65c72d1959e2d91a570ef9f45d521fd5c7.tar.gz
[PATCH] Issue #110: Fix icons vertically stretched
-rw-r--r--.SRCINFO4
-rw-r--r--6091a31f4cb8732252279e802c8ec9f1c3891b38.patch31
-rw-r--r--PKGBUILD15
3 files changed, 46 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c99358e32f9..13a46936584a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-appindicator-git
pkgdesc = Integrates AppIndicators into GNOME Shell.
- pkgver = 20+16+ge2de1b7
+ pkgver = 21+2+g7863517
pkgrel = 1
epoch = 1
url = https://github.com/ubuntu/gnome-shell-extension-appindicator
@@ -12,7 +12,9 @@ pkgbase = gnome-shell-extension-appindicator-git
optdepends = libappindicator-gtk3: support GTK+3 applications
optdepends = libappindicator-sharp: support .net applications
source = gnome-shell-extension-appindicator-git::git+https://github.com/ubuntu/gnome-shell-extension-appindicator.git
+ source = 6091a31f4cb8732252279e802c8ec9f1c3891b38.patch
sha512sums = SKIP
+ sha512sums = fb3375e505b030b9264cf5636468c20248cdfc967746b1f8b284b9769a678ffbad9f5e52b5481961d4dc142517c5b709a500781f50763d15d882f66ac4c9f7b8
pkgname = gnome-shell-extension-appindicator-git
diff --git a/6091a31f4cb8732252279e802c8ec9f1c3891b38.patch b/6091a31f4cb8732252279e802c8ec9f1c3891b38.patch
new file mode 100644
index 000000000000..69bc5aad3b8f
--- /dev/null
+++ b/6091a31f4cb8732252279e802c8ec9f1c3891b38.patch
@@ -0,0 +1,31 @@
+From 6091a31f4cb8732252279e802c8ec9f1c3891b38 Mon Sep 17 00:00:00 2001
+From: Romeo Calota <kicsyromy@gmail.com>
+Date: Mon, 25 Dec 2017 15:20:25 +0200
+Subject: [PATCH] Issue #110: Fix icons vertically stretched
+
+---
+ appIndicator.js | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/appIndicator.js b/appIndicator.js
+index fe629c2..46f01eb 100644
+--- a/appIndicator.js
++++ b/appIndicator.js
+@@ -227,7 +227,7 @@ var IconActor = new Lang.Class({
+ this.height = icon_size * scale_factor
+
+ this._indicator = indicator
+- this._iconSize = icon_size * scale_factor
++ this._iconSize = icon_size
+ this._iconCache = new IconCache.IconCache()
+
+ this._mainIcon = new St.Bin()
+@@ -335,6 +335,8 @@ var IconActor = new Lang.Class({
+ },
+
+ _createIconFromPixmap: function(iconSize, iconPixmapArray) {
++ let scale_factor = St.ThemeContext.get_for_stage(global.stage).scale_factor;
++ iconSize = iconSize * scale_factor
+ // the pixmap actually is an array of pixmaps with different sizes
+ // we use the one that is smaller or equal the iconSize
+
diff --git a/PKGBUILD b/PKGBUILD
index 21e301afd2c9..dbb6d8137af3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Surefire <surefire at cryptomile.net>
pkgname=gnome-shell-extension-appindicator-git
-pkgver=20+16+ge2de1b7
+pkgver=21+2+g7863517
pkgrel=1
epoch=1
pkgdesc="Integrates AppIndicators into GNOME Shell."
@@ -18,14 +18,23 @@ optdepends=(
'libappindicator-gtk3: support GTK+3 applications'
'libappindicator-sharp: support .net applications'
)
-source=("${pkgname}::git+https://github.com/ubuntu/gnome-shell-extension-appindicator.git")
-sha512sums=('SKIP')
+source=(
+ "${pkgname}::git+https://github.com/ubuntu/gnome-shell-extension-appindicator.git"
+ '6091a31f4cb8732252279e802c8ec9f1c3891b38.patch'
+)
+sha512sums=('SKIP'
+ 'fb3375e505b030b9264cf5636468c20248cdfc967746b1f8b284b9769a678ffbad9f5e52b5481961d4dc142517c5b709a500781f50763d15d882f66ac4c9f7b8')
pkgver() {
cd "${pkgname}"
git describe --long --tags | sed 's/^v//;s/-/+/g'
}
+prepare() {
+ cd "${pkgname}"
+ patch -Np1 -i "${srcdir}/6091a31f4cb8732252279e802c8ec9f1c3891b38.patch"
+}
+
package() {
cd "${pkgname}"
# Locate the extension.