summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2020-12-13 14:56:30 +0100
committerChristian Schendel2020-12-13 14:56:30 +0100
commitbc98436639617111e1cdd1cba73eb5e43fbced3e (patch)
tree2f5aadd152275a1f8a060cbbfef02db8d6cc213b
downloadaur-bc98436639617111e1cdd1cba73eb5e43fbced3e.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29476f1bd8eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-applications-overview-tooltip-git
+ pkgdesc = Shows a tooltip over applications icons on applications overview
+ pkgver = 10
+ pkgrel = 1
+ url = https://github.com/RaphaelRochet/applications-overview-tooltip
+ arch = any
+ license = GPL
+ depends = gnome-shell>=3.38
+ provides = gnome-shell-extension-applications-overview-tooltip
+ conflicts = gnome-shell-extension-applications-overview-tooltip
+ source = gnome-shell-extension-applications-overview-tooltip-git-10.tar.gz::https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v10.tar.gz
+ sha256sums = d3b5646d679025f2e1f60ebf0413dbe0eb5d1f2cd437d45a86375c0002f52dc1
+
+pkgname = gnome-shell-extension-applications-overview-tooltip-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3f8c85a99ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Christian Schendel <doppelhelix at gmail dot com>
+pkgname=gnome-shell-extension-applications-overview-tooltip-git
+pkgver=10
+pkgrel=1
+pkgdesc="Shows a tooltip over applications icons on applications overview"
+arch=(any)
+url="https://github.com/RaphaelRochet/applications-overview-tooltip"
+license=('GPL')
+depends=('gnome-shell>=3.38')
+conflicts=("${pkgname%-git}")
+provides=(${pkgname%-git})
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('d3b5646d679025f2e1f60ebf0413dbe0eb5d1f2cd437d45a86375c0002f52dc1')
+
+
+package() {
+ _reponame="applications-overview-tooltip"
+ _uuid="applications-overview-tooltip@RaphaelRochet"
+
+ cd "${srcdir}/${_reponame}-${pkgver}"
+ local dir="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ mkdir -p "${dir}"
+ cp -R * "${dir}"
+}
+