summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-12-09 12:37:37 +0330
committerMohammadreza Abdollahzadeh2017-12-09 12:37:37 +0330
commita98c3d48697065f17418629403a236ae8c04273f (patch)
tree9038e5e749c6ff3f2084831734f7012775274235
downloadaur-a98c3d48697065f17418629403a236ae8c04273f.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--gnome-shell-extension.install13
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..332814f0e2fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Dec 9 09:07:14 UTC 2017
+pkgbase = gnome-shell-extension-arc-menu-git
+ pkgdesc = A GNOME shell extension designed to replace the standard menu found in GNOME 3.
+ pkgver = 15.r29.gf029251
+ pkgrel = 1
+ url = https://github.com/LinxGem33/Arc-Menu
+ install = gnome-shell-extension.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gnome-shell>=3.18
+ source = git+https://github.com/LinxGem33/Arc-Menu.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-arc-menu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e68c42808f29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
+
+pkgname=gnome-shell-extension-arc-menu-git
+pkgver=15.r29.gf029251
+pkgrel=1
+pkgdesc='A GNOME shell extension designed to replace the standard menu found in GNOME 3.'
+arch=(any)
+url="https://github.com/LinxGem33/Arc-Menu"
+license=('GPL2')
+depends=('gnome-shell>=3.18')
+makedepends=('git')
+install='gnome-shell-extension.install'
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd Arc-Menu
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd Arc-Menu
+ make DESTDIR="$pkgdir" INSTALL="system" install
+}
+# vim:set ts=2 sw=2 et:
diff --git a/gnome-shell-extension.install b/gnome-shell-extension.install
new file mode 100644
index 000000000000..484bc1b03f77
--- /dev/null
+++ b/gnome-shell-extension.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "==> ****************************************************"
+ echo "==> Don't forget to Restart GNOME Shell ([Alt]+[F2], r)."
+ echo "==> ****************************************************"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}