summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRanieri Althoff2019-10-28 02:32:41 -0300
committerRanieri Althoff2019-10-28 02:32:41 -0300
commit8eae862355c3a9b668f3e7658b4c7722b2ffd769 (patch)
tree4388de8c4c4ee2e7403c4910a1d1557330b8d6c0
downloadaur-8eae862355c3a9b668f3e7658b4c7722b2ffd769.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD30
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6e0d476c805
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnome-shell-extension-clock-override-git
+ pkgdesc = Customize the date and time format displayed in clock in the top bar in GNOME Shell
+ pkgver = 5+40+g7dd30bc
+ pkgrel = 1
+ url = https://github.com/stuartlangridge/gnome-shell-clock-override
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = zip
+ depends = gnome-shell>=3.18
+ provides = gnome-shell-extension-clock-override
+ conflicts = gnome-shell-extension-clock-override
+ source = gnome-shell-extension-clock-override-git::git+https://github.com/stuartlangridge/gnome-shell-clock-override.git
+ sha512sums = SKIP
+
+pkgname = gnome-shell-extension-clock-override-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ccdadf693590
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0797f661239f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Ranieri Althoff <ranisalt+aur at gmail dot com>
+
+pkgname=gnome-shell-extension-clock-override-git
+pkgver=5+40+g7dd30bc
+pkgrel=1
+pkgdesc='Customize the date and time format displayed in clock in the top bar in GNOME Shell'
+url='https://github.com/stuartlangridge/gnome-shell-clock-override'
+license=('GPL')
+arch=('any')
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+makedepends=('git' 'zip')
+depends=('gnome-shell>=3.18')
+source=("${pkgname}::git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//; s/-/+/g'
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make PREFIX="$pkgdir/usr/share/gnome-shell/extensions/" install
+}