summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Jester-Pfadt2015-06-02 21:13:56 +0200
committerTim Jester-Pfadt2015-06-02 21:13:56 +0200
commit0e88bf2c23aca79d48e6c0faeb07e71c8880670f (patch)
tree11c3923362ee16e1f830d10f10ea418b0853f33c
downloadaur-0e88bf2c23aca79d48e6c0faeb07e71c8880670f.tar.gz
Added my own packages, removed foreign ones.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2cdeba788c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-atom-workspaces-git
+ pkgdesc = A workspaces extension for gnome-shell as part of Ozon OS
+ pkgver = 3.b7b715f
+ pkgrel = 1
+ url = https://github.com/ozonos/atom-workspaces
+ arch = any
+ groups = gnome-shell-extensions
+ license = GPL3
+ depends = gnome-shell
+ source = git+https://github.com/ozonos/atom-workspaces.git
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-atom-workspaces-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ef02ab1f339
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tim Jester-Pfadt <t.jp@gmx.de>
+
+pkgname=gnome-shell-extension-atom-workspaces-git
+pkgver=3.b7b715f
+pkgrel=1
+pkgdesc="A workspaces extension for gnome-shell as part of Ozon OS"
+arch=('any')
+url="https://github.com/ozonos/atom-workspaces"
+groups=('gnome-shell-extensions')
+license=('GPL3')
+depends=('gnome-shell')
+source=('git+https://github.com/ozonos/atom-workspaces.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/atom-workspaces
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd $srcdir/atom-workspaces
+
+ for i in $(find -name "*.js" -o -name "*.json" -o -name "*.css" -o -name "*.xml" -o -name "*.svg")
+ do
+ install -Dm 644 $i $pkgdir/usr/share/gnome-shell/extensions/atom-workspaces@numixproject.org/$i
+ done
+}