summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2015-06-18 17:08:59 +0200
committerPieter Goetschalckx2015-06-18 17:08:59 +0200
commit4f82ca13c85be9bd77e1aaccbbfa18e3b76998a5 (patch)
treeea1eebfbd0ba5e575f79fc486334fef8d03ea6b9
downloadaur-4f82ca13c85be9bd77e1aaccbbfa18e3b76998a5.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
-rw-r--r--gnome-shell-3.16.patch14
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76da8b66fb39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnome-shell-extension-audio-output-switcher-git
+ pkgdesc = Adds a switch for choosing audio output to the system menu.
+ pkgver = r21.5def796
+ pkgrel = 1
+ url = https://github.com/anduchs/audio-output-switcher
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ depends = gnome-shell
+ source = gnome-shell-extension-audio-output-switcher-git::git+https://github.com/anduchs/audio-output-switcher#branch=ports2
+ source = gnome-shell-3.16.patch
+ sha256sums = SKIP
+ sha256sums = bf075f0a396e27af2c71ea9fcdb465504e544ffbcf0e31183f6b76098afdc48d
+
+pkgname = gnome-shell-extension-audio-output-switcher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..929d0c0a760f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
+
+pkgname=gnome-shell-extension-audio-output-switcher-git
+pkgver=r21.5def796
+pkgrel=1
+pkgdesc="Adds a switch for choosing audio output to the system menu."
+arch=('i686' 'x86_64')
+url="https://github.com/anduchs/audio-output-switcher"
+license=('unknown')
+depends=('gnome-shell')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/anduchs/audio-output-switcher#branch=ports2"
+ "gnome-shell-3.16.patch")
+sha256sums=('SKIP'
+ 'bf075f0a396e27af2c71ea9fcdb465504e544ffbcf0e31183f6b76098afdc48d')
+
+prepare() {
+ cd "$pkgname"
+ patch -p0 -i "$srcdir/gnome-shell-3.16.patch"
+}
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ _uuid='audio-output-switcher@anduchs'
+
+ install -Dm644 "metadata.json" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/metadata.json"
+ install -m644 "extension.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
+}
diff --git a/gnome-shell-3.16.patch b/gnome-shell-3.16.patch
new file mode 100644
index 000000000000..e6e956b2804f
--- /dev/null
+++ b/gnome-shell-3.16.patch
@@ -0,0 +1,14 @@
+--- metadata.json
++++ metadata.json
+@@ -2,10 +2,11 @@
+ "shell-version": [
+ "3.10",
+ "3.12",
+- "3.14"
++ "3.14",
++ "3.16"
+ ],
+ "uuid": "audio-output-switcher@anduchs",
+ "name": "Audio Output Switcher",
+ "description": "Adds a switch for choosing audio output to the system menu.",
+ "url": "http://github.com/anduchs/audio-output-switcher"