summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2019-02-21 19:52:15 +0100
committerPieter Goetschalckx2019-02-21 19:52:15 +0100
commit7af7ef9cda13d920dc0751efecac69a519c55a8c (patch)
tree09499519481bc4c311aa3c37382780c4c13a814f
parent4be94daa88432fd4cd78536e9443a0dbc01b2228 (diff)
downloadaur-7af7ef9cda13d920dc0751efecac69a519c55a8c.tar.gz
New repo
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
-rw-r--r--gnome-shell-version.patch16
3 files changed, 13 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee36c78fccbe..63dbf77239fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = gnome-shell-extension-audio-output-switcher-git
pkgdesc = Adds a switch for choosing audio output to the system menu.
- pkgver = r21.5def796
- pkgrel = 3
- url = https://github.com/anduchs/audio-output-switcher
+ pkgver = r27.89e6e29
+ pkgrel = 1
+ url = https://github.com/adaxi/audio-output-switcher
arch = i686
arch = x86_64
license = unknown
makedepends = git
depends = gnome-shell
- source = gnome-shell-extension-audio-output-switcher-git::git+https://github.com/anduchs/audio-output-switcher#branch=ports2
- source = gnome-shell-version.patch
+ source = gnome-shell-extension-audio-output-switcher-git::git+https://github.com/adaxi/audio-output-switcher
sha256sums = SKIP
- sha256sums = eb90f357bf6af150c19cae6d899a2506e3b429b430f335b66e475baf45829e83
pkgname = gnome-shell-extension-audio-output-switcher-git
diff --git a/PKGBUILD b/PKGBUILD
index 1788273549b2..904138e19718 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,16 @@
# Maintainer: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
pkgname=gnome-shell-extension-audio-output-switcher-git
-pkgver=r21.5def796
-pkgrel=3
+pkgver=r27.89e6e29
+pkgrel=1
pkgdesc="Adds a switch for choosing audio output to the system menu."
arch=('i686' 'x86_64')
-url="https://github.com/anduchs/audio-output-switcher"
+url="https://github.com/adaxi/audio-output-switcher"
license=('unknown')
depends=('gnome-shell')
makedepends=('git')
-source=("$pkgname::git+https://github.com/anduchs/audio-output-switcher#branch=ports2"
- "gnome-shell-version.patch")
-sha256sums=('SKIP'
- 'eb90f357bf6af150c19cae6d899a2506e3b429b430f335b66e475baf45829e83')
-
-prepare() {
- cd "$pkgname"
- patch -p0 -i "$srcdir/gnome-shell-version.patch"
-}
+source=("$pkgname::git+https://github.com/adaxi/audio-output-switcher")
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
@@ -32,4 +25,8 @@ package() {
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/metadata.json"
install -m644 "extension.js" \
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
+ install -m644 "utils.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/utils.js"
+ install -Dm644 "schemas/org.gnome.shell.extensions.audio-output-switcher.gschema.xml" \
+ "${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.audio-output-switcher.gschema.xml"
}
diff --git a/gnome-shell-version.patch b/gnome-shell-version.patch
deleted file mode 100644
index 4292434ad7cb..000000000000
--- a/gnome-shell-version.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- metadata.json
-+++ metadata.json
-@@ -2,10 +2,13 @@
- "shell-version": [
- "3.10",
- "3.12",
-- "3.14"
-+ "3.14",
-+ "3.16",
-+ "3.18",
-+ "3.20"
- ],
- "uuid": "audio-output-switcher@anduchs",
- "name": "Audio Output Switcher",
- "description": "Adds a switch for choosing audio output to the system menu.",
- "url": "http://github.com/anduchs/audio-output-switcher"