summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCédric Bellegarde2019-06-11 09:16:40 +0200
committerCédric Bellegarde2019-06-11 09:16:40 +0200
commit025ec9d6cc36382e6b7e575e1d2d274c4651d70c (patch)
tree7cd34deded390dae64e455fb1dcd09f18cfb1bde
parent2c810d6b4d1d8a89efd03b5a39a641ffc2919cfa (diff)
downloadaur-025ec9d6cc36382e6b7e575e1d2d274c4651d70c.tar.gz
Migrate to meson
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a31df117e7d8..cd6575b80ef8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-background-logo-git
pkgdesc = GNOME Shell extension to overlay a logo over the default background
- pkgver = 3.24.0.r0.g16d6fe2
+ pkgver = 3.32.0.r0.g26fce06
pkgrel = 1
url = https://pagure.io/background-logo-extension
arch = any
@@ -9,12 +9,12 @@ pkgbase = gnome-shell-extension-background-logo-git
makedepends = autoconf
makedepends = make
makedepends = gnome-common
+ depends = gnome-shell
+ depends = gnome-backgrounds
source = git+https://pagure.io/background-logo-extension
source = archlinux-wm-gnome.svg
sha256sums = SKIP
sha256sums = ae3223dab86d51ed54ac22c0518102bcd965fe0576839a038e559301cf94cc2c
pkgname = gnome-shell-extension-background-logo-git
- depends = gnome-shell
- depends = gnome-backgrounds
diff --git a/PKGBUILD b/PKGBUILD
index 0fb55f85f438..58ebab7e9599 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
pkgname=gnome-shell-extension-background-logo-git
_name=background-logo-extension
-pkgver=3.24.0.r0.g16d6fe2
+pkgver=3.32.0.r0.g26fce06
pkgrel=1
pkgdesc="GNOME Shell extension to overlay a logo over the default background"
arch=(any)
url="https://pagure.io/background-logo-extension"
+depends=('gnome-shell' 'gnome-backgrounds')
source=(git+${url} 'archlinux-wm-gnome.svg')
sha256sums=('SKIP' 'ae3223dab86d51ed54ac22c0518102bcd965fe0576839a038e559301cf94cc2c')
license=(GPL3)
@@ -17,15 +18,14 @@ pkgver() {
}
build() {
- cd "${srcdir}/${_name}"
- ./autogen.sh --prefix=/usr
- make
+ arch-meson background-logo-extension build
+ ninja -C build
}
package() {
- depends=('gnome-shell' 'gnome-backgrounds')
cd "${srcdir}/${_name}"
sed -i "s@/usr/share/fedora-logos/fedora_lightbackground.svg@/usr/share/archlinux-logos/archlinux_lightbackground.svg@g" schemas/org.fedorahosted.background-logo-extension.gschema.xml
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}"
+ DESTDIR="${pkgdir}" ninja -C build install
install -Dm644 "${srcdir}"/archlinux-wm-gnome.svg $pkgdir/usr/share/archlinux-logos/archlinux_lightbackground.svg
}