summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2017-05-18 01:05:39 +0200
committerPieter Goetschalckx2017-05-18 01:05:39 +0200
commit409ed59bde7744bb9a60ece98591af4334578cbc (patch)
tree2276308946ae4b69f9f80593d36e20491231b3c5
downloadaur-gnome-shell-extension-bettervolume-git.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be19bb40a316
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-bettervolume-git
+ pkgdesc = Allow better interaction with the volume indicator, via mouse scroll/middle-button.
+ pkgver = r38.1a66fab
+ pkgrel = 1
+ url = https://github.com/Tudmotu/gnome-shell-extension-bettervolume
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = gnome-shell
+ source = git+https://github.com/Tudmotu/gnome-shell-extension-bettervolume
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-bettervolume-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58f760686aa0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
+
+_pkgname=gnome-shell-extension-bettervolume
+pkgname=$_pkgname-git
+pkgver=r38.1a66fab
+pkgrel=1
+pkgdesc="Allow better interaction with the volume indicator, via mouse scroll/middle-button."
+arch=('i686' 'x86_64')
+url="https://github.com/Tudmotu/$_pkgname"
+license=('MIT')
+depends=('gnome-shell')
+makedepends=('git')
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ _uuid='bettervolume@tudmotu.com'
+
+ install -Dm644 "metadata.json" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/metadata.json"
+ install -m644 "extension.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
+ install -m644 "convenience.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/convenience.js"
+
+ install -Dm644 "LICENSE.rst" \
+ "${pkgdir}/usr/share/licenses/$pkgname/LICENSE.rst"
+}