summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarry Smith2018-02-20 06:42:14 -0500
committerBarry Smith2018-02-20 06:42:14 -0500
commit91f67ebef8ee808e3b71169696efac99e207ce85 (patch)
tree5c85c78d94effe8afac7e637e1c59c20b7154cb8
downloadaur-91f67ebef8ee808e3b71169696efac99e207ce85.tar.gz
Lightweight GNOME shell extension to change your wallpaper every day to Microsoft Bing's wallpaper
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33d638665b89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gnome-shell-extension-bing-wallpaper
+ pkgdesc = Changes your wallpaper daily to the bing.com background image
+ pkgver = 18
+ pkgrel = 1
+ url = https://github.com/neffo/bing-wallpaper-gnome-extension
+ arch = any
+ license = GPL
+ depends = gnome-shell>=3.18
+ source = https://github.com/neffo/bing-wallpaper-gnome-extension/archive/v18.tar.gz
+ sha512sums = a9a44b0e518583c1894bfc970df4faff8da12698f6f140d12980c1e39cf9cbffa5e91248e2c2ca36dc16ebc078674350d1eda89417355e35a7c6ccae9aabdbf3
+
+pkgname = gnome-shell-extension-bing-wallpaper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab97df93e29c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: dude <brrtsm at gmail dot com>
+
+pkgname=gnome-shell-extension-bing-wallpaper
+_pkgname=bing-wallpaper-gnome-extension-
+pkgver=18
+pkgrel=1
+pkgdesc="Changes your wallpaper daily to the bing.com background image"
+arch=('any')
+url="https://github.com/neffo/bing-wallpaper-gnome-extension"
+license=('GPL')
+depends=('gnome-shell>=3.18')
+source=("https://github.com/neffo/bing-wallpaper-gnome-extension/archive/v${pkgver}.tar.gz")
+sha512sums=('a9a44b0e518583c1894bfc970df4faff8da12698f6f140d12980c1e39cf9cbffa5e91248e2c2ca36dc16ebc078674350d1eda89417355e35a7c6ccae9aabdbf3')
+package() {
+ _uuid='BingWallpaper@ineffable-gmail.com'
+ _install_dir="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+
+ install -dm655 $_install_dir
+ cd "${_pkgname}${pkgver}"
+ cp -r * $_install_dir
+}