summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNattgew2017-11-04 10:41:18 -0700
committerNattgew2017-11-04 10:44:37 -0700
commitdfae2f0dae9393b274e986b8a9c1a90ecc641249 (patch)
treec39b8afd536dadbdfd1ce08f98f2fe41b691c2ee
downloadaur-dfae2f0dae9393b274e986b8a9c1a90ecc641249.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..849a57a84d12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-bitcoin-markets-git
+ pkgdesc = Displays Bitcoin and Altcoin market information in the Gnome Shell.
+ pkgver = 176.6a12763
+ pkgrel = 1
+ url = https://github.com/OttoAllmendinger/gnome-shell-bitcoin-markets/
+ arch = any
+ license = MIT
+ makedepends = git zip unzip gjs
+ depends = gnome-shell
+ source = gnome-shell-extension-bitcoin-markets-git::git://github.com/OttoAllmendinger/gnome-shell-bitcoin-markets.git
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-bitcoin-markets-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc97233fde5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nattgew <nattarchy at gmail dot com>
+
+pkgname=gnome-shell-extension-bitcoin-markets-git
+pkgdesc="Displays Bitcoin and Altcoin market information in the Gnome Shell."
+pkgver=176.6a12763
+pkgrel=1
+arch=(any)
+url='https://github.com/OttoAllmendinger/gnome-shell-bitcoin-markets/'
+license=(MIT)
+depends=('gnome-shell')
+makedepends=('git zip unzip gjs')
+source=("$pkgname::git://github.com/OttoAllmendinger/gnome-shell-bitcoin-markets.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/"$pkgname"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir"/"$pkgname"
+ make
+ mkdir -p $pkgdir/usr/share/gnome-shell/extensions/bitcoin-markets@ottoallmendinger.github.com
+ unzip -q gnome-shell-bitcoin-markets.zip -d $pkgdir/usr/share/gnome-shell/extensions/bitcoin-markets@ottoallmendinger.github.com
+ #rm gnome-shell-bitcoin-markets.zip
+ chmod -R 644 $pkgdir/usr/share/gnome-shell/extensions/*
+}