summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-06 11:47:32 -0700
committerMark Wagie2024-01-06 11:47:32 -0700
commit27222e7005a585356bf2ef1d8c3fa811cbe0cd8a (patch)
tree66c1910b10366a1ed4cc35e5a1c63c85232e0c19
downloadaur-27222e7005a585356bf2ef1d8c3fa811cbe0cd8a.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD45
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f8867268fcf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-bluetooth-battery-meter-git
+ pkgdesc = An extension featuring indicator icons in the system tray, serving as a meter for Bluetooth device battery levels.
+ pkgver = r1.7d69349
+ pkgrel = 1
+ url = https://github.com/maniacx/Bluetooth-Battery-Meter
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = bluez
+ depends = gnome-shell
+ provides = gnome-shell-extension-bluetooth-battery-meter
+ conflicts = gnome-shell-extension-bluetooth-battery-meter
+ source = git+https://github.com/maniacx/Bluetooth-Battery-Meter.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-bluetooth-battery-meter-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd4c6cab6463
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+pkgname=gnome-shell-extension-bluetooth-battery-meter-git
+_uuid=Bluetooth-Battery-Meter@maniacx.github.com
+pkgver=r1.7d69349
+pkgrel=1
+pkgdesc="An extension featuring indicator icons in the system tray, serving as a meter for Bluetooth device battery levels."
+arch=('any')
+url="https://github.com/maniacx/Bluetooth-Battery-Meter"
+license=('GPL3')
+depends=('bluez' 'gnome-shell')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/maniacx/Bluetooth-Battery-Meter.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd Bluetooth-Battery-Meter
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd Bluetooth-Battery-Meter
+ gnome-extensions pack ./ \
+ --extra-source=icons/ \
+ --extra-source=lib/ \
+ --extra-source=preferences/ \
+ --extra-source=ui/ \
+ --podir=po \
+ --force
+}
+
+package() {
+ cd Bluetooth-Battery-Meter
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
+ bsdtar -xvf "${_uuid}.shell-extension.zip" -C \
+ "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/" --no-same-owner
+
+ # Does not detect icons in system and no locale yet
+# mv "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"/{icons,locale} "$pkgdir/usr/share/"
+
+ install -Dm644 schemas/org.gnome.shell.extensions.Bluetooth-Battery-Meter.gschema.xml -t \
+ "$pkgdir/usr/share/glib-2.0/schemas/"
+ rm -rf "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/schemas/"
+}