summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-10-22 15:05:36 -0600
committerMark Wagie2023-10-22 15:05:36 -0600
commit230474fa96caad6175bd07f98d84b7f411f55a1e (patch)
tree84e5e646022a94d8fc9c9b6d910f7870516dfd30
parentc9e4dda0ccecdbaced79e282a1c5bfbbcf6767fa (diff)
downloadaur-230474fa96caad6175bd07f98d84b7f411f55a1e.tar.gz
adapt to upstream blunders
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bc6d50d1291..f6cfad87128b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = gnome-shell-extension-blur-my-shell
pkgdesc = Extension that adds a blur look to different parts of the GNOME Shell
pkgver = 52
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/aunetx/blur-my-shell
arch = any
license = MIT
+ makedepends = git
depends = gnome-shell
- source = blur-my-shell-52.tar.gz::https://github.com/aunetx/blur-my-shell/archive/refs/tags/v52.tar.gz
- sha256sums = 96e49d73ed20674f02f4914276df2f158b92219c3eaa425eef034a593867cec1
+ source = git+https://github.com/aunetx/blur-my-shell.git#commit=78857cf1fa16cbb622d8894bd341ef773c883232
+ sha256sums = SKIP
pkgname = gnome-shell-extension-blur-my-shell
diff --git a/PKGBUILD b/PKGBUILD
index 337c0b53dce7..3f7b6cc8559f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,24 @@
pkgname=gnome-shell-extension-blur-my-shell
_uuid=blur-my-shell@aunetx
pkgver=52
-pkgrel=1
+pkgrel=2
pkgdesc="Extension that adds a blur look to different parts of the GNOME Shell"
arch=('any')
url="https://github.com/aunetx/blur-my-shell"
license=('MIT')
depends=('gnome-shell')
-source=("blur-my-shell-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('96e49d73ed20674f02f4914276df2f158b92219c3eaa425eef034a593867cec1')
+makedepends=('git')
+_commit=78857cf1fa16cbb622d8894bd341ef773c883232 # 52
+source=("git+https://github.com/aunetx/blur-my-shell.git#commit=$_commit")
+sha256sums=('SKIP')
build() {
- cd "blur-my-shell-$pkgver"
+ cd blur-my-shell
make
}
package() {
- cd "blur-my-shell-$pkgver"
+ cd blur-my-shell
install -d "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
bsdtar xvf "build/${_uuid}.shell-extension.zip" \
-C "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/" --no-same-owner