summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-11-19 08:24:13 -0700
committerMark Wagie2022-11-19 08:24:13 -0700
commit77edd3fc0b34d842029d9c309b17714bd80b6bc3 (patch)
tree4259460f2935c1954ac3e7a076f9b4f0ee6a56d2
parentb98249e95146ae29512b4665c5945b5bd994fb95 (diff)
downloadaur-77edd3fc0b34d842029d9c309b17714bd80b6bc3.tar.gz
adopt package
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD49
3 files changed, 27 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f822e3c0e2b4..eac084c1e918 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = gnome-shell-extension-blur-my-shell
pkgdesc = Extension that adds a blur look to different parts of the GNOME Shell
pkgver = 44
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/aunetx/blur-my-shell
arch = any
- license = GPL3
- makedepends = unzip
- depends = dconf
+ license = MIT
+ makedepends = git
depends = gnome-shell
- conflicts = gnome-shell-extension-blur-my-shell-git
source = blur-my-shell-44.tar.gz::https://github.com/aunetx/blur-my-shell/archive/refs/tags/v44.tar.gz
sha256sums = 7046ca26ca9c82aed7a7ccf2cb09769cb15ccbeb5e3cab5c3fceecff356b6cee
diff --git a/.gitignore b/.gitignore
index 018a3de08144..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
+# Ignore everything
*
+
+# But not these files...
+!.gitignore
!PKGBUILD
!.SRCINFO
-!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 1e6095584624..0c115813f21b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,35 @@
-# Maintainer: skrewball <aur at joickle dot com> gitlab.com/skrewball/aur
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: skrewball <aur at joickle dot com> gitlab.com/skrewball/aur
# Contributor: malacology <guoyizhang at malacology dot net>
-
pkgname=gnome-shell-extension-blur-my-shell
-_pkgbase=blur-my-shell
+_pkgname=blur-my-shell
pkgver=44
-pkgrel=1
+pkgrel=2
pkgdesc="Extension that adds a blur look to different parts of the GNOME Shell"
arch=('any')
url="https://github.com/aunetx/blur-my-shell"
-license=('GPL3')
-depends=('dconf' 'gnome-shell')
-makedepends=('unzip')
-conflicts=('gnome-shell-extension-blur-my-shell-git')
-source=("${_pkgbase}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+license=('MIT')
+depends=('gnome-shell')
+makedepends=('git')
+source=("$_pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('7046ca26ca9c82aed7a7ccf2cb09769cb15ccbeb5e3cab5c3fceecff356b6cee')
build() {
- cd "${_pkgbase}-${pkgver}"
- make pot build
- cd build && unzip *.zip
+ cd "$_pkgname-$pkgver"
+ make
}
package() {
- cd "${_pkgbase}-${pkgver}/build"
- local _uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
- local _destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ cd "$_pkgname-$pkgver"
+ _uuid="${_pkgname}@aunetx"
+
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ bsdtar xvf build/${_uuid}.shell-extension.zip \
+ -C "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/"
- install -Dm644 -t "${_destdir}" metadata.json *.js *.css
- install -Dm644 -t "${_destdir}/components" components/*.js
- install -Dm644 -t "${_destdir}/conveniences" conveniences/*.js
- install -Dm644 -t "${_destdir}/dbus" dbus/*.{js,xml}
- install -Dm644 -t "${_destdir}/effects" effects/*.{js,glsl}
- install -Dm644 -t "${_destdir}/preferences" preferences/*.js
- install -Dm644 -t "${_destdir}/ui" ui/*.ui
- cp -r --no-preserve=ownership,mode icons "${_destdir}"
+ install -Dm644 "schemas/org.gnome.shell.extensions.${_pkgname}.gschema.xml" -t \
+ "$pkgdir/usr/share/glib-2.0/schemas/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
- install -Dm644 -t "${pkgdir}/usr/share/glib-2.0/schemas/" schemas/*.xml
- cd locale
- for locale in */
- do
- install -Dm644 -t "${pkgdir}/usr/share/locale/${locale}/LC_MESSAGES" "${locale}/LC_MESSAGES"/*.mo
- done
+ rm -rf "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/schemas/"
}