summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskrewball2022-05-09 22:36:57 -0300
committerskrewball2022-05-09 22:36:57 -0300
commitba1cc1d7ea19004ae6fef63fcb670230e7439fed (patch)
treec1d325feafbbbac511773a0e7fe5d5b9df7bb829
parentb24c86c708e6d70a4fe84f2b51efd13a02ee6949 (diff)
downloadaur-ba1cc1d7ea19004ae6fef63fcb670230e7439fed.tar.gz
updpkg: gnome:blur-my-shell v35
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b295c3004b97..a2f7df25c704 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = gnome-shell-extension-blur-my-shell
pkgdesc = Extension that adds a blur look to different parts of the GNOME Shell
- pkgver = 33
+ pkgver = 35
pkgrel = 1
url = https://github.com/aunetx/blur-my-shell
arch = any
license = GPL3
+ makedepends = unzip
depends = dconf
depends = gnome-shell
conflicts = gnome-shell-extension-blur-my-shell-git
- source = blur-my-shell-33.tar.gz::https://github.com/aunetx/blur-my-shell/archive/refs/tags/v33.tar.gz
- sha256sums = c32f7bfbada3ec4e70c7bd61e5e7a570c1606c8314b2c389d8afbc4881334a75
+ source = blur-my-shell-35.tar.gz::https://github.com/aunetx/blur-my-shell/archive/refs/tags/v35.tar.gz
+ sha256sums = 855270dd0012e665706d451226d4da492ba1857084f83c76b273e14f10da4014
pkgname = gnome-shell-extension-blur-my-shell
diff --git a/PKGBUILD b/PKGBUILD
index b93be0b90bc3..b594731ac37d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,40 @@
pkgname=gnome-shell-extension-blur-my-shell
_pkgbase=blur-my-shell
-pkgver=33
+pkgver=35
pkgrel=1
pkgdesc="Extension that adds a blur look to different parts of the GNOME Shell"
arch=('any')
url="https://github.com/aunetx/blur-my-shell"
license=('GPL3')
depends=('dconf' 'gnome-shell')
+makedepends=('unzip')
conflicts=('gnome-shell-extension-blur-my-shell-git')
source=("${_pkgbase}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('c32f7bfbada3ec4e70c7bd61e5e7a570c1606c8314b2c389d8afbc4881334a75')
+sha256sums=('855270dd0012e665706d451226d4da492ba1857084f83c76b273e14f10da4014')
build() {
cd "${_pkgbase}-${pkgver}"
make
+ cd build && unzip *.zip
}
package() {
cd "${_pkgbase}-${pkgver}/build"
local _uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
local _destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
-
+
install -Dm644 -t "${_destdir}" metadata.json *.js *.css
install -Dm644 -t "${_destdir}/components" components/*.js
install -Dm644 -t "${_destdir}/conveniences" conveniences/*.js
install -Dm644 -t "${_destdir}/preferences" preferences/*.js
install -Dm644 -t "${_destdir}/ui" ui/*.ui
cp -r --no-preserve=ownership,mode icons "${_destdir}"
- install -Dm644 -t "${pkgdir}/usr/share/glib-2.0/schemas/" schemas/*.xml
+
+ install -Dm644 -t "${pkgdir}/usr/share/glib-2.0/schemas/" schemas/*.xml
+ cd locale
+ for locale in */
+ do
+ install -Dm644 -t "${pkgdir}/usr/share/locale/${locale}/LC_MESSAGES" "${locale}/LC_MESSAGES"/*.mo
+ done
}