summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-11-03 11:37:47 -0600
committerMark Wagie2023-11-03 11:37:47 -0600
commitd625171e1cc2f79a95ef11282034d6990686361f (patch)
treeb802582b9551794f5965d16035463d71314b4e45
parent230474fa96caad6175bd07f98d84b7f411f55a1e (diff)
downloadaur-d625171e1cc2f79a95ef11282034d6990686361f.tar.gz
53
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6cfad87128b..2e3754b8ad55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = gnome-shell-extension-blur-my-shell
pkgdesc = Extension that adds a blur look to different parts of the GNOME Shell
- pkgver = 52
- pkgrel = 2
+ pkgver = 53
+ pkgrel = 1
url = https://github.com/aunetx/blur-my-shell
arch = any
license = MIT
makedepends = git
depends = gnome-shell
- source = git+https://github.com/aunetx/blur-my-shell.git#commit=78857cf1fa16cbb622d8894bd341ef773c883232
+ source = git+https://github.com/aunetx/blur-my-shell.git#commit=f479cb6ade4b91533926947eb132ff28bc62a3e5
sha256sums = SKIP
pkgname = gnome-shell-extension-blur-my-shell
diff --git a/PKGBUILD b/PKGBUILD
index 3f7b6cc8559f..682db6205f47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,23 @@
# Contributor: malacology <guoyizhang at malacology dot net>
pkgname=gnome-shell-extension-blur-my-shell
_uuid=blur-my-shell@aunetx
-pkgver=52
-pkgrel=2
+pkgver=53
+pkgrel=1
pkgdesc="Extension that adds a blur look to different parts of the GNOME Shell"
arch=('any')
url="https://github.com/aunetx/blur-my-shell"
license=('MIT')
depends=('gnome-shell')
makedepends=('git')
-_commit=78857cf1fa16cbb622d8894bd341ef773c883232 # 52
-source=("git+https://github.com/aunetx/blur-my-shell.git#commit=$_commit")
+_commit=f479cb6ade4b91533926947eb132ff28bc62a3e5 # tags/v53^0
+source=("git+https://github.com/aunetx/blur-my-shell.git#commit=${_commit}")
sha256sums=('SKIP')
+pkgver() {
+ cd blur-my-shell
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
build() {
cd blur-my-shell
make