summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-04-19 18:49:38 -0600
committerMark Wagie2021-04-19 18:49:38 -0600
commite09a01b79ce98badf463d20a984452cb234b1a9c (patch)
tree205936112d1d3be468684521b89361996aeab1ee
downloadaur-e09a01b79ce98badf463d20a984452cb234b1a9c.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD37
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31af4eebb5f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-blur-my-shell-git
+ pkgdesc = Extension that adds a blur look to different parts of the GNOME Shell
+ pkgver = r39.764e5b1
+ pkgrel = 1
+ url = https://github.com/aunetx/blur-my-shell
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-extension-blur-my-shell
+ conflicts = gnome-shell-extension-blur-my-shell
+ source = git+https://github.com/aunetx/blur-my-shell.git#branch=gnome-40
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-blur-my-shell-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e069fa22540
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=gnome-shell-extension-blur-my-shell-git
+_pkgname=blur-my-shell
+pkgver=r39.764e5b1
+pkgrel=1
+pkgdesc="Extension that adds a blur look to different parts of the GNOME Shell"
+arch=('any')
+url="https://github.com/aunetx/blur-my-shell"
+license=('unknown')
+depends=('gnome-shell')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/aunetx/blur-my-shell.git#branch=gnome-40')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ _uuid='blur-my-shell@aunetx'
+
+ install -d "$pkgdir/usr/share/gnome-shell/extensions"
+ cp -r build "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+
+ install -d "$pkgdir/usr/share/glib-2.0/schemas"
+ ln -s "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/schemas/org.gnome.shell.extensions.$_uuid.gschema.xml" \
+ "$pkgdir/usr/share/glib-2.0/schemas"
+}