summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiab Neiroukh2020-04-19 14:11:02 +0100
committerDiab Neiroukh2020-04-19 14:13:33 +0100
commita2ac8a2085233d8ad79fc7cf68bd8c630cdb92e5 (patch)
tree94edee2c61a455e08ccaf1405064097ed598037a
downloadaur-a2ac8a2085233d8ad79fc7cf68bd8c630cdb92e5.tar.gz
🔥
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f577f93b00a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-blyr
+ pkgdesc = Apply a Blur Effect to GNOME Shell UI elements
+ pkgver = 7
+ pkgrel = 1
+ url = https://github.com/yozoon/gnome-shell-extension-blyr
+ arch = any
+ license = GPL
+ makedepends = unzip
+ depends = gnome-shell>=3.34
+ optdepends = clutter-gtk: configuring blyr
+ noextract = blyr@yozoon.dev.gmail.com.zip
+ source = https://github.com/yozoon/gnome-shell-extension-blyr/releases/download/v7/blyr@yozoon.dev.gmail.com.zip
+ b2sums = d4d56d889bc3fe59abafd9b54f71e666dd8651ad7bab9bbae830f95f09c948417ad67906f9cd6a903610df882dd534f4303fec87877641a808843aae3353a3ea
+
+pkgname = gnome-shell-extension-blyr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43e938081b9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Diab Neiroukh <officiallazerl0rd@gmail.com>
+
+pkgname="gnome-shell-extension-blyr"
+pkgver=7
+pkgrel=1
+pkgdesc="Apply a Blur Effect to GNOME Shell UI elements"
+arch=("any")
+url="https://github.com/yozoon/gnome-shell-extension-blyr"
+license=("GPL")
+depends=("gnome-shell>=3.34")
+optdepends=("clutter-gtk: configuring blyr")
+makedepends=("unzip")
+source=("https://github.com/yozoon/gnome-shell-extension-blyr/releases/download/v${pkgver}/blyr@yozoon.dev.gmail.com.zip")
+noextract=("blyr@yozoon.dev.gmail.com.zip")
+b2sums=("d4d56d889bc3fe59abafd9b54f71e666dd8651ad7bab9bbae830f95f09c948417ad67906f9cd6a903610df882dd534f4303fec87877641a808843aae3353a3ea")
+
+prepare()
+{
+ install -d "gnome-shell-extension-blyr"
+ unzip "blyr@yozoon.dev.gmail.com.zip" -d "gnome-shell-extension-blyr"
+}
+
+package()
+{
+ local _uuid="blyr@yozoon.dev.gmail.com"
+
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ cp -r "gnome-shell-extension-blyr/"* "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+}