summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach2016-11-11 13:26:49 -0700
committerZach2016-11-11 13:26:49 -0700
commit1c4d1acecc0a4077c59c9453702d5738a575508d (patch)
tree22c2d44611be32c89148df11a48e319402d25b89
downloadaur-1c4d1acecc0a4077c59c9453702d5738a575508d.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4f095ccdeb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Nov 11 20:26:36 UTC 2016
+pkgbase = gnome-shell-extension-bottompanel-git
+ pkgdesc = Move your GNOME 3.16+ shell panel to the bottom.
+ pkgver = 27.fa9d21c
+ pkgrel = 1
+ url = https://github.com/horst3180/gnome-shell-extension-bottompanel
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell>=3.16
+ source = gnome-shell-extension-bottompanel::git+https://github.com/Thoma5/gnome-shell-extension-bottompanel.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-bottompanel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d30cffa26128
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: zach <zach {at} zach-adams {dot} com>
+
+pkgname=gnome-shell-extension-bottompanel-git
+_pkgname=gnome-shell-extension-bottompanel
+_pkgauthor=Thoma5
+pkgver=27.fa9d21c
+pkgrel=1
+pkgdesc="Move your GNOME 3.16+ shell panel to the bottom."
+arch=('any')
+url="https://github.com/horst3180/${_pkgname}"
+license=('GPL3')
+depends=('gnome-shell>=3.16')
+makedepends=('git')
+source=(${_pkgname}::"git+https://github.com/${_pkgauthor}/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/gnome-shell/extensions/"
+ cp -r "$_pkgname" "${pkgdir}/usr/share/gnome-shell/extensions/bottompanel@tmoer93"
+}