summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-06-29 21:39:21 -0400
committerTony Lambiris2017-06-29 21:39:21 -0400
commit21743eee7c523e70dc492787f55125cf5700edd9 (patch)
tree3df089bdfde17687886c89724f98018f0f3c4e17
downloadaur-21743eee7c523e70dc492787f55125cf5700edd9.tar.gz
initial commit for gnome-shell-extension-bumblebee-status
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92647010da54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-bumblebee-status-git
+ pkgdesc = GNOME Shell extension that shows the status of the NVIDIA GPU
+ pkgver = 9.9cc6f3a
+ pkgrel = 1
+ url = https://github.com/dsboger/gnome-shell-extension-bumblebee-status
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell
+ depends = unzip
+ source = git+https://github.com/dsboger/gnome-shell-extension-bumblebee-status.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-bumblebee-status-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71033db6dbe3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=gnome-shell-extension-bumblebee-status-git
+_gitname=gnome-shell-extension-bumblebee-status
+pkgver=9.9cc6f3a
+pkgrel=1
+pkgdesc="GNOME Shell extension that shows the status of the NVIDIA GPU"
+arch=('any')
+url="https://github.com/dsboger/gnome-shell-extension-bumblebee-status"
+license=('GPL3')
+depends=('gnome-shell' 'unzip')
+makedepends=('git')
+source=('git+https://github.com/dsboger/gnome-shell-extension-bumblebee-status.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+build() {
+ cd $_gitname
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make ${MAKEFLAGS} zip-file
+}
+
+package() {
+ cd $_gitname
+ _extid="gnome-shell-extension-bumblebee-status.dsboger@gmail.com"
+ _extpath="${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
+ install -dm755 "${_extpath}"
+ unzip -q -d "${_extpath}" "${_gitname}.zip"
+}