summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-12-18 22:33:13 +0300
committerIgor Dyatlov2021-12-18 22:33:13 +0300
commit5faebd402c56c1cc735c83ca18e1a3cd0fb34d20 (patch)
treead21eb2b0343ec6d86ada10930751200c5cc4488
downloadaur-5faebd402c56c1cc735c83ca18e1a3cd0fb34d20.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20f638652258
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gnome-shell-extension-burn-my-windows
+ pkgdesc = Disintegrate your apps the old-school way.
+ pkgver = 2
+ pkgrel = 1
+ url = https://github.com/Schneegans/Burn-My-Windows
+ arch = any
+ license = GPL3
+ makedepends = zip
+ depends = gnome-shell>=1:40
+ source = https://github.com/Schneegans/Burn-My-Windows/archive/v2.tar.gz
+ b2sums = 7432b84c7652f16f04d75d5b635ee0bff531ccc066efc4614909afc8d21c6ada466f0020867d80f3fc80b3e434758346cf5d8f5dc247b5d2591805d7c320c68f
+
+pkgname = gnome-shell-extension-burn-my-windows
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85f9899b2b63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=gnome-shell-extension-burn-my-windows
+_pkgname=Burn-My-Windows
+pkgver=2
+pkgrel=1
+pkgdesc="Disintegrate your apps the old-school way."
+arch=('any')
+url="https://github.com/Schneegans/Burn-My-Windows"
+license=('GPL3')
+depends=('gnome-shell>=1:40')
+makedepends=('zip')
+source=(${url}/archive/v$pkgver.tar.gz)
+b2sums=('7432b84c7652f16f04d75d5b635ee0bff531ccc066efc4614909afc8d21c6ada466f0020867d80f3fc80b3e434758346cf5d8f5dc247b5d2591805d7c320c68f')
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ make zip
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+
+ local uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/${uuid}"
+ bsdtar -xvf ${uuid}.zip -C "$pkgdir/usr/share/gnome-shell/extensions/${uuid}"
+}