summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Candau2023-10-10 13:11:31 +0200
committerRobin Candau2023-10-10 13:11:31 +0200
commiteb0d7d9bf2e642d857c7e81a1db03c4c5402876e (patch)
treee6cecd540596c81dc6ed9d43ca540dce53980065
parent1f395718e87973c5c78343ef7011eb90249644a5 (diff)
downloadaur-eb0d7d9bf2e642d857c7e81a1db03c4c5402876e.tar.gz
Update the package function according to upstream changes
https://github.com/eonpatapon/gnome-shell-extension-caffeine/commit/0211604eff1caa82639d248023e5ce1d137ad0a5 https://github.com/eonpatapon/gnome-shell-extension-caffeine/commit/a9a15f770f94b128210fd2078a3c6ca99ecf4142
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec59dcab9a08..74af21d964a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-caffeine
pkgdesc = Extension for GNOME shell to disable screensaver and auto suspend
pkgver = 50
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/eonpatapon/gnome-shell-extension-caffeine
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 32d8f5bdd73f..188ac7e5c07e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Robin Candau <antiz@archlinux.org>
pkgname=gnome-shell-extension-caffeine
+_uuid=caffeine@patapon.info
pkgver=50
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='Extension for GNOME shell to disable screensaver and auto suspend'
arch=('any')
@@ -19,8 +20,9 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
- install -d "${pkgdir}/usr/share/gnome-shell/extensions"
- cp -a caffeine@patapon.info/ "${pkgdir}/usr/share/gnome-shell/extensions"
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ bsdtar -xvf "${_uuid}.zip" -C "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ chown -R root:root "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}