summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Donat2016-11-20 19:51:55 +0100
committerMichal Donat2016-11-20 19:51:55 +0100
commitce8c93de4a18dd488b57e5672e9bafc43727f7d4 (patch)
treee6082bb776917807079d610f30042750488ca93a
downloadaur-ce8c93de4a18dd488b57e5672e9bafc43727f7d4.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--gschemas.install30
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a6758a5b227
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-calc-git
+ pkgdesc = Simple gnome shell calculator in run dialog that you can use with alt+f2
+ pkgver = r10.26c8c65
+ pkgrel = 1
+ url = https://github.com/danigm/gnome-shell-calculator
+ install = gschemas.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gnome-shell
+ source = git+https://github.com/danigm/gnome-shell-calculator
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-calc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..381ae9a8ceb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Michal DonĂ¡t <michal at donat dot cz>
+pkgname=gnome-shell-extension-calc-git
+_pkgname=gnome-shell-calculator
+pkgver=r10.26c8c65
+pkgrel=1
+pkgdesc="Simple gnome shell calculator in run dialog that you can use with alt+f2"
+arch=('any')
+url="https://github.com/danigm/gnome-shell-calculator"
+license=('GPL2')
+depends=('gnome-shell')
+makedepends=('git')
+install='gschemas.install'
+source=("git+https://github.com/danigm/gnome-shell-calculator")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ for i in $(find -type f); do
+ install -Dm 644 "$i" "${pkgdir}/usr/share/gnome-shell/extensions/calc@danigm.wadobo.com/${i}"
+ done
+}
diff --git a/gschemas.install b/gschemas.install
new file mode 100644
index 000000000000..7f4546e45017
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,30 @@
+post_install() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_install
+}
+
+post_upgrade() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_upgrade
+}
+
+post_remove() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+instructions_install() {
+ /bin/cat << EOF
+
+Restart GNOME Shell ([Alt]+[F2], r).
+Activate the extension with gnome-tweak-tool.
+
+EOF
+}
+
+instructions_upgrade() {
+ /bin/cat << EOF
+
+Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension.
+
+EOF
+}