summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2020-03-08 18:36:44 +0200
committerChristoph Fink2020-03-08 18:36:44 +0200
commit770a9e184f500d752b4d0fe8cac752743b83ce6a (patch)
treee9c8f18867fd3d66f8ba6ba6b4c5c824786176bb
parentfd787ab8ca9ecb0c915ddfee3ff58976bbd24ed0 (diff)
downloadaur-770a9e184f500d752b4d0fe8cac752743b83ce6a.tar.gz
v12-0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD71
-rw-r--r--install_node_modules.patch14
3 files changed, 70 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85ec3ba3146f..d05d03e43064 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = gnome-shell-extension-cast-to-tv
pkgdesc = Cast files to your Chromecast or other devices over local network
- pkgver = 9
- pkgrel = 1
+ pkgver = 12
+ pkgrel = 0
url = https://github.com/Rafostar/gnome-shell-extension-cast-to-tv
- arch = any
+ arch = x86_64
license = GPL
makedepends = npm
- makedepends = gettext
depends = gnome-shell
depends = ffmpeg
+ depends = nodejs
optdepends = python-nautilus: Nautilus integration
- source = https://github.com/Rafostar/gnome-shell-extension-cast-to-tv/archive/v9.tar.gz
- sha256sums = b67df23d85de7feb779cda4872e54a59b521e789a7183f60f5fdd297dcc746db
+ source = gnome-shell-extension-cast-to-tv-12.tar.gz::https://github.com/Rafostar/gnome-shell-extension-cast-to-tv/archive/v12.tar.gz
+ source = install_node_modules.patch
+ sha256sums = 163f749ddf79b9d6a578644bfaaf6436f18c3711cd943c39f3358c5fc5bd615f
+ sha256sums = b24fa4e6b04cae500ec267345ac48f9c92452e0d9ad798ac28132984387b98cc
pkgname = gnome-shell-extension-cast-to-tv
diff --git a/PKGBUILD b/PKGBUILD
index ad243a44cdcb..1ca15cda4d56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,65 @@
# Maintainer: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
+# Maintainer: peippo <christoph+aur@christophfink.com>
pkgname=gnome-shell-extension-cast-to-tv
-pkgver=9
-pkgrel=1
pkgdesc="Cast files to your Chromecast or other devices over local network"
-arch=('any')
+_gnomeextensionname="cast-to-tv@rafostar.github.com"
+
url="https://github.com/Rafostar/$pkgname"
-license=('GPL')
-depends=('gnome-shell' 'ffmpeg')
+arch=("x86_64")
+license=("GPL")
+
+pkgver=12
+pkgrel=0
+
+depends=(
+ "gnome-shell"
+ "ffmpeg"
+ "nodejs"
+)
optdepends=(
- 'python-nautilus: Nautilus integration'
+ "python-nautilus: Nautilus integration"
+)
+makedepends=(
+ "npm"
)
-makedepends=('npm' 'gettext')
-source=("https://github.com/Rafostar/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('b67df23d85de7feb779cda4872e54a59b521e789a7183f60f5fdd297dcc746db')
-build() {
- cd "$pkgname-$pkgver"
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/Rafostar/$pkgname/archive/v$pkgver.tar.gz"
+ "install_node_modules.patch"
+)
+sha256sums=(
+ "163f749ddf79b9d6a578644bfaaf6436f18c3711cd943c39f3358c5fc5bd615f"
+ "b24fa4e6b04cae500ec267345ac48f9c92452e0d9ad798ac28132984387b98cc"
+)
- make compilemo
- npm install
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch --forward --strip=1 --input "${srcdir}/install_node_modules.patch"
}
package() {
- cd "$pkgname-$pkgver"
- uuid="cast-to-tv@rafostar.github.com"
+ cd "${pkgname}-${pkgver}"
+
+ npm install --cache "${srcdir}/npm-cache"
- install -dm755 "$pkgdir/usr/share/gnome-shell/extensions/$uuid"
- install -dm777 "$pkgdir/usr/share/gnome-shell/extensions/$uuid/config"
- cp -r *.js *.json appIcon node_scripts webplayer "$pkgdir/usr/share/gnome-shell/extensions/$uuid/"
+ make install PKGDIR="${pkgdir}"
- install -dm755 "$pkgdir/usr/share/locale"
- cp -r locale/* "$pkgdir/usr/share/locale/"
+ install \
+ -Ddm755 \
+ "${pkgdir}/usr/share/locale"
+ cp \
+ -aR \
+ locale/* \
+ "${pkgdir}/usr/share/locale/"
- install -Dm644 "schemas/org.gnome.shell.extensions.cast-to-tv.gschema.xml" \
- "$pkgdir/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.cast-to-tv.gschema.xml"
+ install \
+ -Dm644 \
+ "schemas/org.gnome.shell.extensions.cast-to-tv.gschema.xml" \
+ "${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.cast-to-tv.gschema.xml"
- install -Dm644 nautilus/nautilus-cast-to-tv.py -t "$pkgdir/usr/share/nautilus-python/extensions/"
+ install \
+ -Dm644 \
+ nautilus/nautilus-cast-to-tv.py \
+ "$pkgdir/usr/share/nautilus-python/extensions/nautilus-cast-to-tv.py"
}
diff --git a/install_node_modules.patch b/install_node_modules.patch
new file mode 100644
index 000000000000..d37426ebdb96
--- /dev/null
+++ b/install_node_modules.patch
@@ -0,0 +1,14 @@
+diff --unified --recursive --text a/Makefile b/Makefile
+--- a/Makefile 2020-02-18 20:09:18.000000000 +0200
++++ b/Makefile 2020-03-07 11:53:35.010020726 +0200
+@@ -7,8 +7,8 @@
+ TOLOCALIZE = extension.js widget.js playlist.js file-chooser.js prefs.js node_scripts/messages.js
+ MSGSRC = $(wildcard ./po/cast-to-tv/*.po)
+ POTFILE = ./po/cast-to-tv/cast-to-tv.pot
+-ZIPFILES = *.js *.json node_scripts webplayer schemas locale appIcon nautilus COPYING README.md
+-INSTALLPATH = ~/.local/share/gnome-shell/extensions
++ZIPFILES = *.js *.json node_scripts node_modules webplayer schemas locale appIcon nautilus COPYING README.md
++INSTALLPATH = $(PKGDIR)/usr/share/gnome-shell/extensions
+
+ # Add-ons translations #
+ POFOLDERS = $(wildcard ./po/cast-to-tv-*-addon)