summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2019-01-08 16:56:38 +0100
committerPieter Goetschalckx2019-01-08 16:56:38 +0100
commit8ac12a798bb8704d12026e095bf45d86380f14e5 (patch)
tree8013c00732d0571406f8d554b6d74fd4faafa2f1
downloadaur-8ac12a798bb8704d12026e095bf45d86380f14e5.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7f98fae9ae7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-cast-to-tv
+ pkgdesc = Cast files to your Chromecast or other devices over local network
+ pkgver = 5
+ pkgrel = 1
+ url = https://github.com/Rafostar/gnome-shell-extension-cast-to-tv
+ arch = any
+ license = GPL
+ makedepends = npm
+ makedepends = gettext
+ depends = gnome-shell
+ depends = ffmpeg
+ source = https://github.com/Rafostar/gnome-shell-extension-cast-to-tv/archive/v5.tar.gz
+ sha256sums = 0ccfc6b5f55b2f9e468170bcae0df34e9cc744366583192969f4831049016902
+
+pkgname = gnome-shell-extension-cast-to-tv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9573af7e81a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
+
+pkgname=gnome-shell-extension-cast-to-tv
+pkgver=5
+pkgrel=1
+pkgdesc="Cast files to your Chromecast or other devices over local network"
+arch=('any')
+url="https://github.com/Rafostar/$pkgname"
+license=('GPL')
+depends=('gnome-shell' 'ffmpeg')
+makedepends=('npm' 'gettext')
+source=("https://github.com/Rafostar/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('0ccfc6b5f55b2f9e468170bcae0df34e9cc744366583192969f4831049016902')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ make compilemo
+ npm install
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ uuid="cast-to-tv@rafostar.github.com"
+
+ install -dm755 "$pkgdir/usr/share/gnome-shell/extensions/$uuid"
+ cp -r *.js *.json webplayer "$pkgdir/usr/share/gnome-shell/extensions/$uuid/"
+
+ install -dm755 "$pkgdir/usr/share/locale"
+ cp -r locale/* "$pkgdir/usr/share/locale/"
+
+ install -Dm644 "schemas/org.gnome.shell.extensions.cast-to-tv.gschema.xml" \
+ "$pkgdir/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.cast-to-tv.gschema.xml"
+}