summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2020-03-28 18:14:55 +0200
committerChristoph Fink2020-03-28 18:14:55 +0200
commit0fbf2611727ec4dd5540b284496129b0706950d3 (patch)
treeaa04dec19f366524d8c11b2b791785accc40dbf9
parent45af619d789be567e221b3fdd6ff8eacafcf8d5a (diff)
downloadaur-0fbf2611727ec4dd5540b284496129b0706950d3.tar.gz
Added cleaning steps to package(), as recommended in https://wiki.archlinux.org/index.php/Node.js_package_guidelines
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67733a11cf12..eb588ac14c03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-cast-to-tv-git
pkgdesc = Cast files to your Chromecast or other devices over local network
pkgver = v12.r33.g1483c4e
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Rafostar/gnome-shell-extension-cast-to-tv-git
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 094bbf1d10ae..77c0f53dc3c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ arch=("x86_64")
license=("GPL")
pkgver=v12.r33.g1483c4e
-pkgrel=1
+pkgrel=2
provides=("gnome-shell-extension-cast-to-tv")
conflicts=("gnome-shell-extension-cast-to-tv")
@@ -70,4 +70,12 @@ package() {
-Dm644 \
nautilus/nautilus-cast-to-tv.py \
"$pkgdir/usr/share/nautilus-python/extensions/nautilus-cast-to-tv.py"
+
+ # Non-deterministic race in npm gives 777 permissions to random directories.
+ # See https://github.com/npm/npm/issues/9359 for details.
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "${pkgdir}"
}