summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2022-03-14 11:09:40 +0100
committerChristian Schendel2022-03-14 11:09:40 +0100
commit5dff85eb60fc2c91a2072222492f9519c5b14efc (patch)
treedc021f2f815c3b3e21728e2567a6524ef2f46976
parent7be4c6a99e9bb5aec30de2185bbc8057c0c52344 (diff)
downloadaur-5dff85eb60fc.tar.gz
update
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 239d165a187f..972a6d03d779 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-compiz-windows-effect-git
pkgdesc = Compiz wobbly windows effect with libanimation engine.
- pkgver = r17.41128b2
+ pkgver = r18.d72dd59
pkgrel = 1
url = https://github.com/hermes83/compiz-windows-effect
install = gnome-shell-extension-compiz-windows-effect.install
diff --git a/PKGBUILD b/PKGBUILD
index 0006b2859214..3e9a8df0773b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Schendel <doppelhelix@gmail.com>
pkgname=gnome-shell-extension-compiz-windows-effect-git
-pkgver=r17.41128b2
+pkgver=r18.d72dd59
pkgrel=1
pkgdesc="Compiz wobbly windows effect with libanimation engine."
arch=('any')
@@ -10,7 +10,8 @@ install=${pkgname%-git}.install
license=('GPL3')
depends=("gnome-shell>=3.28")
optdepends=("libanimation-gnome-shell-git")
-makedepends=('git' 'glib2')
+makedepends=('git'
+ 'glib2')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("${pkgname%-git}::git+${url}.git")
@@ -38,4 +39,8 @@ package() {
install -Dm 644 {} ${destdir}/{} \;
install -Dm644 "${srcdir}/${pkgname%-git}/schemas/${schema}" \
"${pkgdir}/usr/share/glib-2.0/schemas/${schema}"
+# rebuild compiled GSettings schemas if missing
+ if [[ ! -f "${destdir}/schemas/gschemas.compiled" ]]; then
+ glib-compile-schemas "${destdir}/schemas"
+ fi
}