summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-03-23 20:32:21 +0100
committerXZS2016-03-23 20:32:21 +0100
commit211e3d043ad8184ca612ddda32b4fcdd857afbd6 (patch)
tree1eda7e67f1939c049162ca5ccb8ec30690414159
parent58405cf4283ccdb8fc9405d680e223d36950b890 (diff)
downloadaur-211e3d043ad8184ca612ddda32b4fcdd857afbd6.tar.gz
end grep trickery, it has been busted
Unbelievably, also traditional tools like grep are regularly updated still today. Version 2.24 forbid the combination of some features with the -z option. This was exactly what was exploited here to make grep ignore newlines so they would not interrupt JSON dissection. More information about the change can be found at the bottom of the respective release notes. [1] Fixing it costs an invocation of tr to remove the bothersome newlines. Because the files are read within "find -exec" where input redirection is not readily possible, cat has to be invoked to start the pipeline. The grep script got only a tiny bit simpler by adhering to the new restriction and leaving newlines to tr. Thanks to AUR users jmauss, Asher256 and vinadoros for pointing to the critical line. [1]: http://savannah.gnu.org/forum/forum.php?forum_id=8477
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b77ab2bd0e18..a5b7c10fa074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -67,7 +67,8 @@ depends[125]=gnome-shell
package_20_version() {
local compatibles=($(\
find -path ./pkg -type d -prune -o \
- -name metadata.json -exec grep -Pzo '(?s)(?<="shell-version": \[)[^\[\]]*(?=\])' '{}' \; | \
+ -name metadata.json -exec cat '{}' \; | \
+ tr -d '\n' | grep -Po '(?<="shell-version": \[)[^\[\]]*(?=\])' | \
tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
depends+=("gnome-shell>=3.${compatibles[0]}")
local max="${compatibles[-1]}"