summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-11-01 13:58:58 +0100
committerXZS2016-11-01 13:58:58 +0100
commit272839046b2f182eaf22c99a98602293bbd1c615 (patch)
treeb6b7e6d72f857664947cd92e76c67daf285391c6
parent891aed5f9a5d8e6f37a7a8e20cf22ab541f3cd03 (diff)
downloadaur-272839046b2f182eaf22c99a98602293bbd1c615.tar.gz
choose newest extension source
Some extensions authors introduce build steps required before installing. Their execution normally produces a completed variant of the extension code in a subdirectory, difficult to tell apart from the original source. The find condition introduced herein proves the process against such cases to come. It always chooses the files created last, ensuring that a build which occurred after mere unpacking will always take precedence.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d0649255d18..86657fd50610 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,7 +34,8 @@ package() {
}
package_01_locate() {
msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; -printf %h -quit)"
+ cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
+ -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
}