summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-22 11:52:04 +0200
committerXZS2016-04-22 11:52:04 +0200
commit5e679976dbc05dd3208fd6c6bae9611ccbac2c52 (patch)
tree57b86fe6b39bfab289bc7db15c272b22e4a9a25b
parent1427efb64f1be7fb20747e9b320499d2dca6a040 (diff)
downloadaur-5e679976dbc05dd3208fd6c6bae9611ccbac2c52.tar.gz
fix version comparison
Comparing the minor version to a string of minor and major will never succeed. Originally, a restriction on the current shell version was omitted for historical reasons - most packages did so when dependencies were defined manually. This now turns into a concious decision to - permit the usage of the extension in instable gnome-shell versions - the ones with odd minor version numbers - where incompatibilities are introduced gradually. - ease the transition from one stable gnome-shell version - the ones with even minor version numbers - to the next. In an ideal world, all extensions should have been updates before the update hits the repositories. But as Arch is quite more on the edge than developers of some of the extensions, this is not the case more often than not.
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7cef0903ea31..85d7e7f3a2c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ url="https://github.com/dmo60/CoverflowAltTab"
license=('GPL')
makedepends+=(jq)
-source+=("${_giturl:-release::${url/github.com/api.github.com\/repos}/releases/latest}")
+source+=("release::${_giturl:-${url/github.com/api.github.com\/repos}/releases/latest}")
md5sums+=('SKIP')
prepare() {
@@ -72,7 +72,7 @@ package_20_version() {
tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
depends+=("gnome-shell>=3.${compatibles[0]}")
local max="${compatibles[-1]}"
- if [ "3.$max" != $(
+ if [ "$max" != $(
gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
) ]; then
depends+=("gnome-shell<3.$((${max%%.*} + 1))")