summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2021-08-10 20:37:57 +0900
committerhayao2021-08-10 20:37:57 +0900
commit806d75d566119ed7ef531344ac3e5575e9e17bb7 (patch)
tree3caf8581ae88d1ce49b69df722276cc7be6d778d
parenta5f64536d7493af233ba50afe73c35c86ec9c56f (diff)
downloadaur-806d75d566119ed7ef531344ac3e5575e9e17bb7.tar.gz
Simple PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD84
2 files changed, 13 insertions, 78 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9de5e2daf8f5..e4a8189ad49f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = gnome-shell-extension-coverflow-alt-tab
pkgdesc = Replacement of Alt-Tab, iterates through windows in a cover-flow manner
- pkgver = 1.8.1
+ pkgver = 1.11
pkgrel = 1
url = https://github.com/dmo60/CoverflowAltTab
install = gschemas.install
arch = any
license = GPL
- makedepends = jq
- depends = gnome-shell
- source = tags::https://api.github.com/repos/dmo60/CoverflowAltTab/tags
+ source = https://github.com/dmo60/CoverflowAltTab/archive/refs/tags/v1.11.zip
md5sums = SKIP
pkgname = gnome-shell-extension-coverflow-alt-tab
-
diff --git a/PKGBUILD b/PKGBUILD
index 0b9ac86c4da3..6bf655a42982 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,83 +1,21 @@
-# Maintainer: XZS <d dot f dot fischer at web dot de>
-# This PKGBUILD is maintained on GitHub <https://github.com/dffischer/gnome-shell-extensions>.
-# You may find it convenient to file issues and pull requests there.
+# Maintainer : Yamada Hayao <hayao@fascode.net>
+# Contributer: XZS <d dot f dot fischer at web dot de>
+
pkgname=gnome-shell-extension-coverflow-alt-tab
-pkgver=1.8.1
+pkgver=1.11
pkgrel=1
pkgdesc="Replacement of Alt-Tab, iterates through windows in a cover-flow manner"
arch=('any')
url="https://github.com/dmo60/CoverflowAltTab"
license=('GPL')
-
-makedepends+=(jq)
-source+=("tags::${_giturl:-${url/github.com/api.github.com\/repos}/tags}")
+source+=("${url}/archive/refs/tags/v${pkgver}.zip")
md5sums+=('SKIP')
+install=gschemas.install
+_dir="CoverflowAltTab-${pkgver}"
-prepare() {
- local url="$(jq -r '.[0].tarball_url' tags)"
- local archive="${url##*/}"
- if [ ! -e "$archive" ]; then
- curl -Lo "$archive" "$url"
- fi
- tar xf "$archive"
-}
-
-pkgver() {
- jq -r '.[0].name' tags | grep -o '[[:digit:].]*$'
-}
-package() {
- for function in $(declare -F | grep -Po 'package_[[:digit:]]+[[:alpha:]_]*$')
- do
- $function
- done
-}
-package_01_locate() {
- msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
- -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
- extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
- destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
-}
-
-package_02_install() {
- msg2 'Installing extension code...'
- find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) \
- -exec install -Dm644 -t "$destdir" '{}' +
-}
-package_10_locale() {
- msg2 'Installing translations...'
- (
- cd locale
- for locale in */
- do
- install -Dm644 -t "$pkgdir/usr/share/locale/$locale/LC_MESSAGES" "$locale/LC_MESSAGES"/*.mo
- done
- )
-}
-if [ -z "$install" ]
-then
- install=gschemas.install
-fi
-
-package_10_schemas() {
- msg2 'Installing schemas...'
- find -name '*.xml' -exec install -Dm644 -t "$pkgdir/usr/share/glib-2.0/schemas" '{}' +
-}
-depends[125]=gnome-shell
-
-package_20_version() {
- local compatibles=($(\
- find -path ./pkg -type d -prune -o \
- -name metadata.json -exec cat '{}' \; | \
- tr -d '\n' | grep -Po '(?<="shell-version": \[)[^\[\]]*(?=\])' | \
- tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
- depends+=("gnome-shell>=3.${compatibles[0]}")
- local max="${compatibles[-1]}"
- if [ "$max" != $(
- gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
- ) ]; then
- depends+=("gnome-shell<3.$((${max%%.*} + 1))")
- fi
- unset depends[125]
+package(){
+ cd "${srcdir}/${_dir}"
+ mkdir -p "${pkgdir}/usr/share/gnome-shell/extensions"
+ make all LOCALINSTALL=true SUPER_PATH="${pkgdir}/usr/share/gnome-shell/extensions"
}