summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-11-01 14:48:50 +0100
committerXZS2016-11-01 14:48:50 +0100
commitb9e3c7c5d79a229d9802e126c869e9d6b5057ddb (patch)
tree971a5b9082845b0cada719dbd8350a0d7ba8005f
parent272839046b2f182eaf22c99a98602293bbd1c615 (diff)
downloadaur-b9e3c7c5d79a229d9802e126c869e9d6b5057ddb.tar.gz
propagate upstream update
The latest version is only tagged and not marked as a release, so to track it, a corresponding switch was necessary.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53524fa8faa4..f064c6ec7ebf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-coverflow-alt-tab
pkgdesc = Replacement of Alt-Tab, iterates through windows in a cover-flow manner
- pkgver = 1.2
+ pkgver = 1.3
pkgrel = 1
url = https://github.com/dmo60/CoverflowAltTab
install = gschemas.install
@@ -8,7 +8,7 @@ pkgbase = gnome-shell-extension-coverflow-alt-tab
license = GPL
makedepends = jq
depends = gnome-shell
- source = release::https://api.github.com/repos/dmo60/CoverflowAltTab/releases/latest
+ source = tags::https://api.github.com/repos/dmo60/CoverflowAltTab/tags
md5sums = SKIP
pkgname = gnome-shell-extension-coverflow-alt-tab
diff --git a/PKGBUILD b/PKGBUILD
index 86657fd50610..29091bdc9504 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# You may find it convenient to file issues and pull requests there.
pkgname=gnome-shell-extension-coverflow-alt-tab
-pkgver=1.2
+pkgver=1.3
pkgrel=1
pkgdesc="Replacement of Alt-Tab, iterates through windows in a cover-flow manner"
arch=('any')
@@ -11,20 +11,20 @@ url="https://github.com/dmo60/CoverflowAltTab"
license=('GPL')
makedepends+=(jq)
-source+=("release::${_giturl:-${url/github.com/api.github.com\/repos}/releases/latest}")
+source+=("tags::${_giturl:-${url/github.com/api.github.com\/repos}/tags}")
md5sums+=('SKIP')
prepare() {
- local url="$(jq -r '.assets[0].browser_download_url' release)"
+ local url="$(jq -r '.[0].tarball_url' tags)"
local archive="${url##*/}"
if [ ! -e "$archive" ]; then
curl -Lo "$archive" "$url"
fi
- unzip -o "$archive"
+ tar xf "$archive"
}
pkgver() {
- jq -r .tag_name release | grep -o '[[:digit:].]*$'
+ jq -r '.[0].name' tags | grep -o '[[:digit:].]*$'
}
package() {
for function in $(declare -F | grep -Po 'package_[[:digit:]]+[[:alpha:]_]*$')